H - Flip Game poj 1753

问题描述

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

输入

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

输出

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

样例输入

bwwb
bbwb
bwwb
bwww

样例输出

4


这道题我第一反应是bfs,类似前面存储状态的方法 ,然后我试试了用dfs去做这道题;代码如下:

#include <iostream>
#include <stdio.h>
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <stack>
#include <queue>
#include <string.h>
#include <vector>
#include <queue>
#include <cmath>
#include <iomanip>
using namespace std;

int n;bool mark;
char ma[4][4];

bool isok()//判断颜色是否都一样
{
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
        if(ma[i][j]!=ma[0][0])
            return false;
    return true;
}

void fz(int x,int y)//翻转函数
{
    ma[x][y]=ma[x][y]=='w'?'b':'w';
    if(y<3)ma[x][y+1]=ma[x][y+1]=='w'?'b':'w';
    if(y>0)ma[x][y-1]=ma[x][y-1]=='w'?'b':'w';
    if(x<3)ma[x+1][y]=ma[x+1][y]=='w'?'b':'w';
    if(x>0)ma[x-1][y]=ma[x-1][y]=='w'?'b':'w';
}

void dfs(int x,int y,int cur)
{
    //之前把判断越界放在了这个地方,所以再判断
    //wwww
    //wwww
    //wwwb
    //wwbb
    //时就出错了;
    if(cur==n)
    {
        if(isok())
        {
            mark=true;
        }
            return ;
    }
if(x>3||y>3)return ;

 fz(x,y);
        if(y<3)
       dfs(x,y+1,cur+1);
       else
        dfs(x+1,0,cur+1);//从下一行第一个开始翻
      if(mark)
          return;

      //不翻转的情况
        fz(x,y);//翻回来
        if(y<3)
         dfs(x,y+1,cur);

        else
       dfs(x+1,0,cur);



}

int main()
{
    for(int i=0;i<4;i++)
    {
        cin>>ma[i];
    }
    mark=false;
    for(n=0;n<=16;n++)
    {
        dfs(0,0,0);
        
        if(mark)
            break;
    }
    if(mark)
        cout<<n<<endl;
        else
        cout<<"Impossible"<<endl;
}

ps:

之前第一行翻到底的时候就下意思的往下走dfs(x+1,y,cur+1);

然后就一直WA.......

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值