F - Stealing Harry Potter's Precious hdu 4771

问题描述

  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
 

输入

  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0
 

输出

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
 

样例输入

    
    
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
 

样例输出

   
   
-1 5


这道题类似前面那道胜利大逃亡,同样 用bfs+状态存储来做这道题,
值得一提的是 我前第一次做这个题的时候没考虑 珠宝在墙上,以及在起点,在同一个房间的情况,然后就一直WA。
然后过了段时间我写这份题解用当初AC的代码已经不能AC了,然后我把这些特殊情况去掉就又AC了。


AC代码:
#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;

char ma[105][105];int vis[105][105][1<<9];
int n,m;int xx,yy;//xxyy表示起点;
int k;//表示k个钥匙;

//表示4个方向
int dx[]={-1,0,0,1};
int dy[]={0,1,-1,0};

struct node
{
    int x,y,mark,step,num;//表示该节点的坐标,拥有钥匙的状态,当前步数,和当前钥匙数量
    node(int a1,int a2,int a3,int a4,int a5)
    {
        x=a1;y=a2;mark=a3;step=a4;num=a5;
    }
};

int bfs()
{
    queue<node>que;
    node no1(xx,yy,0,0,0);
    que.push(no1);
    if(ma[xx][yy]=='@')//起点不是珠宝的情况
    vis[xx][yy][no1.mark]=1;
    while(!que.empty())
    {
        node no=que.front();
        que.pop();

        for(int i=0;i<4;i++)
        {
            int mark1=no.mark;
            int x=no.x+dx[i];
            int y=no.y+dy[i];
            if(x>=n||y>=m||x<0||y<0||ma[x][y]=='#')continue;//碰到墙的情况,出界的情况,第一次AC时这里还加了句||vis[x][y]==1;
            if(ma[x][y]>='a'&&ma[x][y]<='z'&&!vis[x][y][mark1])//如果是珠宝,并且是没有访问过的状态
            {
                
                if(mark1&1<<(ma[x][y]-'a'))//如果这个珠宝已经有了
                {
                    que.push(node(x,y,mark1,no.step+1,no.num));
                }
                else//珠宝没有
                {
                    mark1|=1<<(ma[x][y]-'a');
                if(no.num+1==k)
                    return no.step+1;
                que.push(node(x,y,mark1,no.step+1,no.num+1));
                }
               
                vis[x][y][mark1]=1;
            }

            else if(!vis[x][y][mark1])//路的情况
            {
                vis[x][y][mark1]=1;
                que.push(node(x,y,mark1,no.step+1,no.num));
            }
        }

    }
    return -1;
}

int main()
{
    while(scanf("%d%d",&n,&m))
    {
        memset(ma,0,sizeof(ma));
        memset(vis,0,sizeof(vis));
        if(n==0&&m==0)
            break;
        for(int i=0;i<n;i++)
        {
            scanf("%s",&ma[i]);
                for(int j=0;j<m;j++)
                {
                    if(ma[i][j]=='@')
                {
                    xx=i,yy=j;//起点
                }
            }
        }

        cin>>k;
        for(int i=0;i<k;i++)
        {
            int aa,bb;
            cin>>aa>>bb;
            aa--;bb--;
            //if(ma[aa][bb]=='#'||(ma[aa][bb]>='a'&&ma[aa][bb]<='z'))//珠宝在墙里面或者在同一个房间
            //{
            //    k--;i--;continue;
            //}
            ma[aa][bb]='a'+i;
        }
        //if(k==0)cout<<0<<endl;
        //else
        cout<<bfs()<<endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值