poj 3280 Cheapest Palindrome(区间dp)

问题描述

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.


输入

Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

输出

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

样例输入

3 4
abcb
a 1000 1100
b 350 700
c 200 800

样例输出

900




我们用dp[i][j]表示从第i位到第j位这个区间变成回文串的最小花费。
那么 ,我们可以由dp[i+1][j]这个子列 通过在首位加上第j个元素或者尾位减去第i个元素来使(i,j)变成回文串,或者是由dp[i][j-1]进行同样的操作使(i,j)变成回文串。
因此我们的状态转移方成就为:
dp[i][j]=min(dp[i+1][j]+cost[ch[i]-'a'],dp[i][j]);
dp[i][j]=min(dp[i][j-1]+cost[ch[j]-'a'],dp[i][j]);
代码如下:
<span style="font-size:18px;">#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

const int INF=99999999;
int n,m;
int cost[30];
int dp[2002][2002];

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        char ch[2002];
        scanf("%s",&ch);
        for(int i=0;i<n;i++)
        {
            char a[2];int x,y;
            scanf("%s",&a);
            scanf("%d%d",&x,&y);
            cost[a[0]-'a']=min(x,y);
        }
        for(int k=2;k<=m;k++)
        {
            for(int i=0,j=i+k-1;j<m;i++,j++)
            {
                dp[i][j]=INF;
                if(ch[i]==ch[j])
                    dp[i][j]=dp[i+1][j-1];
                else
                {
                    dp[i][j]=min(dp[i+1][j]+cost[ch[i]-'a'],dp[i][j]);
                    dp[i][j]=min(dp[i][j-1]+cost[ch[j]-'a'],dp[i][j]);
                }

            }
        }

        
printf("%d\n",dp[0][m-1]);
    }
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值