poj 2239 Selecting Courses(二分图匹配)

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects.

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him?

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

简单的二分图匹配,used数组用来保存是否访问的节点,避免死循环。例如2-->a之后如果已经有了1-->a,则dfs(1),如果不用used标记的话然后继续1-->a,
然后又dfs(2),2-->a。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int ma[305][100];int used[305];int link[305];
int n;

int dfs(int x)
{
    for(int i=1;i<=84;i++)
    {
        if(ma[x][i]&&used[i]==0)
        {
            used[i]=1;
                int tem=link[i];
                link[i]=x;
                if(tem==0||dfs(tem))return 1;
                link[i]=tem;
        }
    }
    return 0;
}

int solve()
{
    memset(link,0,sizeof(link));

    int ans=0;
    for(int i=1;i<=n;i++)
    {memset(used,0,sizeof(used));
        if(dfs(i))ans++;
    }
    return ans;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(ma,0,sizeof(ma));
        for(int i=1;i<=n;i++)
        {
            int t;
            scanf("%d",&t);
            ma[i][0]=t;
            for(int j=1;j<=t;j++)
            {
                int x,y;
                scanf("%d %d",&x,&y);
                ma[i][(x-1)*12+y]=1;
            }
        }
        printf("%d\n",solve());
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值