HDU 1114 动态规划 或者完全背包问题 关于这个题,安利一个背包问题,恰好填满和可以剩余的博客,链接如下:
http://blog.csdn.net/insistgogo/article/details/8579597
然后本题的链接如下:
http://acm.hdu.edu.cn/showproblem.php?pid=1114
C - hdu 1114
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit
Status
Practice
HDU 1114
Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
本题的大意就是,第一行是n组数据,第二行就是存钱罐的重量和加完钱之后的重量,第三行是有几种金币,后面n行分别是n中金币的价值和重量,让你求,恰好等于钱的重量的最少的钱的价值是多少。然后按照样例输出即可。注释不多结合题意应该可以看懂。
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
const int MAX = 1e9;
int V;
int f[10005]; // 当前的状态,就是最小值
int w[10005]; // 物品的价值,也就是金币的大小
int v[10005]; // 物品的体积,也就是金币的重量
using namespace std;
int main()
{
int t, n, m, k; // V就是总体积,总金额
cin >> t;
while(t--){
cin >> n >> m;
V = m - n;
cin >> k ;
for(int i = 0 ; i < k ; i++)
cin >> w[i] >> v[i];
for(int i = 0 ; i <= V ; i++)
f[i] = MAX;
f[0] = 0;
for(int i = 0 ; i < k ; i++)
for(int j = v[i] ; j <= V ; j++){
f[j] = min(f[j], f[j-v[i]] + w[i]);
}
if(f[V] == 1e9)
cout << "This is impossible." << endl;
else
printf("The minimum amount of money in the piggy-bank is %d.\n",f[V]);
}
return 0;
}