POJ-2411 Mondriaan's Dream(轮廓线dp)

Mondriaan's Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 16906 Accepted: 9755

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

假设n=5,m=5

11111
11S4S3S2
S1S0X  
     
     

本题的状态为d[i][j][S]表示 当前以[i,j]格为末尾的轮廓线状态为<S3,S2,S1,S0,X>的值对应二进制表示时且S3之前的所有格子的值都为1时的方法总数

设当前为第[3,3]格,上一格为[3,2],则可以得到上一格的轮廓线状态为:S=<s[2,3],s[2,4],s[2,5],s[2,1],s[2,2]> (s[i,j]∈{0,1})

这一格的轮廓线状态为SS=<s[2,4],s[2,5],s[3,1],s[3,2],X>

那么如何由S转移到SS呢?

条件:
①如果第[i,j]格不放骨牌,那么第[i-1,j]格一定要是被填充过
②如果第[i,j]格放向上的骨牌,i>1且第[i-1,j]格一定要是没被填充过
③如果第[i,j]格放向左的骨牌,j>1第[i-1,j]格一定要是被填充过且[i,j-1]没被填充过
④如果第[i,j]格放向下的骨牌,这种情况和[i+1,j]格放向上的骨牌相同,因此不用考虑

得到状态转移方程:
①S&(1<<(m-1))==1时,dp[i][j][S<<1]+=dp[i][j-1][S]
②i>1且S&(1<<(m-1))==0时,dp[i][j][S<<1|1]+=dp[i][j-1][S]
③j>1且S&1==0时,dp[i][j][S<<1|3]+=dp[i][j-1][S]

#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long LL;
const int MX = 1<<11;
int n,m,cur;
LL dp[2][MX];
void update(int S,int SS){
    //只有新的轮廓线最高位是1时才更新
    if(SS&(1<<m)) dp[cur][SS^(1<<m)]+=dp[cur^1][S];
}
int main(){
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&m),n||m){
        int mx=(1<<m)-1;
        memset(dp,0,sizeof(dp));
        cur=0;
        dp[cur][mx]=1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                cur^=1;
                memset(dp[cur],0,sizeof(dp[cur]));
                for(int S=0;S<=mx;S++){
                    update(S,S<<1);//不放
                    if(i>1&&(S>>(m-1)&1)==0) update(S,(S<<1)|(1<<m)|1);//上放
                    else if(j>1&&(S&1)==0) update(S,S<<1|3);//左放
                }
            }
        }
        printf("%lld\n",dp[cur][mx]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值