poj2411 Mondriaan's Dream(状压dp)

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!
Input
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output
For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0
Sample Output
1
0
1
2
3
5
144
51205

都在代码里了。

/**
    *我们一行一行的放,实际上影响当前行的是上一行的竖直放的格子
    *那么我们可以枚举竖直放的状态,然后去搜索可以横着放置的方案数,然后乘上到上一行(上一行竖直位置相同)为止的方案数即可(下面体现的是每次加)
    *二进制表示当前行的放置状态0表示没放,也就是当前块要竖着放,1表示已经横着放了
    *那么对于下一行,搜索的时候对状态取一个反就可以了。(太巧妙了)
**/


#include <cstdio>
#include <cstring>

using namespace std;
typedef long long LL;

int n,m;
LL dp[15][1<<11];
LL temp;

//搜索当前i行横着放的种类数
//i表示行,state表示当前状态为state,位置为k
//当前状态的位置为1表示横着放了,为0表示竖着放。
//所以每次dp之前对状态取一个反
void dfs(int i,int state,int k)
{
    if(k >= m)
    {
        dp[i][state] += temp;
        return ;
    }
    dfs(i,state,k+1);
    if(k<=m-2 && !(state&1<<k) && !(state&1<<(k+1)))dfs(i,state|1<<k|1<<(k+1),k+2);
}

int main()
{
    while(~scanf("%d%d",&n,&m)&&n)
    {
        //如果都为奇数肯定是不存在的
        if(n&1 && m&1)
        {
            puts("0");
            continue;
        }
        memset(dp,0,sizeof dp);
        //一开始temp肯定为1
        temp = 1;
        //先搜索第一行
        dfs(0,0,0);
        //枚举剩余的行
        for(int i = 1; i < n; ++i)
        {
            //枚举状态
            for(int j = 0; j < 1<<m; ++j)
            {
                //记录到上一行为止的方案数
                if(dp[i-1][j])temp = dp[i-1][j];
                else continue;
                //搜索当前行可以摆放的方案数
                dfs(i,j^((1<<m)-1),0);
            }
        }
        printf("%I64d\n",dp[n-1][(1<<m)-1]);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值