POJ2376-Cleaning Shifts-区间贪心

原题链接
Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19831 Accepted: 5047
Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
    Sample Input

3 10
1 7
3 6
6 10
Sample Output

2
Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.
Source

USACO 2004 December Silver

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=25000 + 10;
const int maxlen=1000000 + 10;
typedef pair<int,int> P;
P p[maxn];
int n,len;
bool cmp(P x,P y){
    return x.first < y.first;
}
int solve(int can,int latest,int num){
    if(latest >= len) return num;
    int begin = latest +1;
    //找到从begin开始工作的工作时间最晚的牛
    for(int i=can;i<n;i++){
        if(p[i].first <= begin){
            latest=max(latest,p[i].second);
        }
        else{
            can=i;
            break;
        }
    }
    if(latest < begin) return -1;//说明没有一个至少在latest+1时间工作的牛,那么这肯定是错误的
    else return solve(can,latest,num+1);
}
int main(){
    scanf("%d%d",&n,&len);
    for(int i=0;i<n;i++){
        int b,e;
        scanf("%d%d",&b,&e);
        p[i]= make_pair(b,e);
    }
    sort(p,p+n,cmp);
    int sum=solve(0,0,0);
    cout << sum << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值