统计难题(字典树还有一种是看起来很简洁的stl)

Time Limit:2000MS Memory Limit:65535KB 64bit IO Format:%I64d & %I64u
这道题作为字典树的理解题最好不过了。

Description
Ignatius最近遇到一个难题, 老师交给他很多单词( 只有小写字母组成, 不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量( 单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表, 每行一个单词, 单词的长度不超过10, 它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问, 每行一个提问, 每个提问都是一个字符串. 

注意: 本题只有一组测试数据, 处理到文件结束.
Output
对于每个提问, 给出以该字符串为前缀的单词的数量.
Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc 
Sample Output

2
3
1
0 



1:线段树

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <iomanip>
#define inf 0x3f3f3f3f
using namespace std;
void Insert(char *s);
int Find(char *s2);
struct node
{
    int son[30];
    int val;
};
node tree[1000005];
int num=1;
char s[15];
char s2[15];
int main()
{
    while(cin.getline(s,14))
    {
        if(s[0]=='\0')
            break;
        Insert(s);
    }
    while(cin.getline(s2,14))
    {
        cout<<Find(s2)<<endl;
    }
    return 0;
}
void Insert(char *s)//建树
{
    int root=0;
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int p=s[i]-'a';
        if(!tree[root].son[p])
            tree[root].son[p]=num++;
        root=tree[root].son[p];
        tree[root].val++;
    }
}
int Find(char *s2)//查找
{
    int root=0;
    int len=strlen(s2);
    for(int j=0;j<len;j++)
    {
        int p=s2[j]-'a';
        if(!tree[root].son[p])
            return 0;
        root=tree[root].son[p];
    }
    return tree[root].val;
}

2:stl来自http://blog.csdn.net/qingshui23/article/details/47417907

#include <iostream>
#include <cstring>
#include <cstdio>
#include <map>

using namespace std;

char str[20];
int main()
{
    map<string, int> m;
    while(gets(str))
    {
        int len = strlen(str);
        if(!len)
            break;
        for(int i=len; i>0; i--)
        {
            str[i] = '\0';
            m[str]++;
        }
    }
    while(gets(str))
    {
        printf("%d\n",m[str]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值