487-3279

题目描述

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino‘s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens‘‘ number 3-10-10-10. The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: A, B, and C map to 2 D, E, and F map to 3 G, H, and I map to 4 J, K, and L map to 5 M, N, and O map to 6 P, R, and S map to 7 T, U, and V map to 8 W, X, and Y map to 9 There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

输入

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

输出

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: No duplicates.

样例输入

124873279ITS-EASY888-45673-10-10-10888-GLOPTUT-GLOP967-11-11310-GINOF101010888-1200-4-8-7-3-2-7-9-487-3279

样例输出

310-1010 2487-3279 4888-4567 3
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char map[26] = {'2', '2', '2', '3', '3', '3', '4', '4', '4',
                '5', '5', '5', '6', '6', '6', '7', '7', '7',
                '7', '8', '8', '8', '9', '9', '9', '9'};//按键映射表

char phone[100000][9];    //全部电话号码

int n;                    //电话号码的数量

char number[80];        //一个未经处理的电话号码


int main()
{
    int loop;                    //循环变量

    int phone_i=0, phone_j=0;    //phone数组的下标

    int tag = 0;                //重复标志,0没有处于一个重复,1有重复

    int count = 1;                //重复次数


    scanf("%d", &n);

    for(phone_i=0; phone_i<n; phone_i++){//格式化所有输入数据为111-1111的形式

        scanf("%s", number);
        for(loop=0; number[loop]!='\0'; loop++){//检查每一个字符

            if(phone_j == 3){//第四个字符必须是'-'

                phone[phone_i][phone_j] = '-';
                phone_j++;
            }
            if(number[loop]>='0' && number[loop]<='9'){//当前字符是数字

                phone[phone_i][phone_j] = number[loop];
            }
            else if(number[loop]>='A' && number[loop]<='Z'){//当前字符是大写字母

                phone[phone_i][phone_j] = map[number[loop]-'A'];
            }
            else if(number[loop] == '-'){//忽略'-'

                continue;
            }
            phone_j++;
        }
        phone_j = 0;
    }

    //排序全部电话号码

    qsort(phone, n, 9, strcmp);

    for(loop=1; loop<n; loop++){//检查重复次数,输出结果

        if(strcmp(phone[loop], phone[loop-1]) == 0){
            tag = 1;
            count++;
        }
        else{//没有重复

            if(count > 1){
                printf("%s %d\n", phone[loop-1], count);
            }
            count = 1;
        }
    }
    if(count > 1){//查看最后一条记录是否有重复

        printf("%s %d\n", phone[loop-1], count);
    }
    if(!tag)
        printf("No duplicates.\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值