E - Counting Cliques HDU - 5952

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph.

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

Output

For each test case, output the number of cliques with size S in the graph.

Sample Input

3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6

Sample Output

3
7
15

dfs 注意的是 建表时建从小到大的单向边 可以避免重复

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
int mp[110][110];
int n, m, k;
int sum = 0;
int s[110];
int top = 0;
int head[110];
int tol;
struct node{
    int u;
    int v;
    int next;
}p[1100];
int judge(int x){
    int flag = 1;
    for(int i = 0; i < top; i++){
        if(mp[s[i]][x] == 0){
            flag = 0;
            break;
        }
    }
    return flag;
}
void init(){
    for(int i = 0; i <= n; i++){
        head[i] = -1;
    }
    memset(mp, 0, sizeof(mp));
    tol = 0;
    top = 0;
}
void addedge(int u, int v){
    p[tol].u = u;
    p[tol].v = v;
    p[tol].next = head[u];
    head[u] = tol++;
}
void dfs(int u, int step){
    if(step == k){
        sum++;
        return;
    }
    //cout << step << endl;
    if(u >= n)return;
    for(int i = head[u]; i != -1; i = p[i].next){
        int v = p[i].v;
        if(judge(v)){
            s[top++] = v;
            dfs(v, step + 1);
            //s[top--];
            top--;
        }
    }
}
int main(){
    int t;
    scanf("%d", &t);
    while(t--){
        scanf("%d %d %d", &n, &m, &k);
        init();
        for(int i = 0; i < m; i++){
            int u, v;
            scanf("%d %d", &u, &v);
            if(u > v)swap(u, v);
            addedge(u, v);
            mp[u][v] = mp[v][u] = 1;
        }
        sum = 0;
        for(int i = 1; i <= n; i++){
            top = 0;
            s[top++] = i;
           // cout << '*' << sum << endl;
            dfs(i, 1);
        }
        printf("%d\n", sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值