2017 Multi-University Training Contest - Team 5-1008 & hdu6092、Rikka with Subset

题目:

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1An and their sum is m . Then for each subset S of A , Yuta calculates the sum of S .

Now, Yuta has got 2n numbers between [0,m] . For each i[0,m] , he counts the number of i s he got as Bi .

Yuta shows Rikka the array Bi and he wants Rikka to restore A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number t(1t70) , the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n50,1m104) .

The second line contains m+1 numbers B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with n numbers A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
  
  
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
 
 
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$

题意:给你一个B数组,共m+1个数,求A数组。B[i] 代表A序列中的所有子集之和为i的有B[i]个,A序列总和为m,共n个元素。

思路:大的数都是由很多个小的数组成,从小到大枚举 i ,然后判断我们需要用几个 i ,用dp数组来维护此时共凑到多少个i,不够的(t>0)我们就只能直接添加i ,接着在每求出A序列的一部分这个过程中,更新后续的B序列,更新完的

B[i]就是 i 在A序列中出现的次数......发现每次做动态规划、dp的问题,总能被自己蠢哭,脑子不够用~

code:

#include<bits/stdc++.h>
using namespace std;
__int64 a[10005],b[10005],dp[10005];   //dp[i]表示加和为i的子集个数
int main()
{
        int t,n,m,i,j,k;
        scanf("%d",&t);
        while(t--){
                scanf("%d%d",&n,&m);
                for(i=0;i<=m;i++) scanf("%I64d",&b[i]);
                memset(dp,0,sizeof(dp));
                k=1;dp[0]=1;   //初始化值
                for(i=1;i<=m;i++){
                        int t=b[i]-dp[i];   //A序列中值为i的个数=和为i的子集个数-已经凑到的和为i的个数
                        while(t--){
                                a[k++]=i;
                                for(j=m;j>=i;j--) dp[j]+=dp[j-i];   //和为j的子集个数相加更新B序列
                        }
                }
                for(i=1;i<=n;i++) printf("%I64d%c",a[i],i==n?'\n':' ');
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值