UVA-10534-Wavio Sequence(最长单调递增子序列长度NlogN)

Wavio is a sequence of integers. It has some interesting properties.
• Wavio is of odd length i.e. L = 2 ∗ n + 1.
• The first (n + 1) integers of Wavio sequence makes a strictly increasing sequence.
• The last (n + 1) integers of Wavio sequence makes a strictly decreasing sequence.
• No two adjacent integers are same in a Wavio sequence.
For example 1, 2, 3, 4, 5, 4, 3, 2, 0 is an Wavio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is
not a valid wavio sequence. In this problem, you will be given a sequence of integers. You have to find
out the length of the longest Wavio sequence which is a subsequence of the given sequence. Consider,
the given sequence as :
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1.
Here the longest Wavio sequence is : 1 2 3 4 5 4 3 2 1. So, the output will be ‘9’.
Input
The input file contains less than 75 test cases. The description of each test case is given below. Input
is terminated by end of file.
Each set starts with a postive integer, N (1 ≤ N ≤ 10000). In next few lines there will be N
integers.
Output
For each set of input print the length of longest wavio sequence in a line.
Sample Input
10
1 2 3 4 5 4 3 2 1 10
19
1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1
5
1 2 3 4 5
Sample Output
9
9
1

题意:找出满足条件子序列的最大长度。条件要求序列长度为N*2-1,前N个数是严格递增,后N个数是严格递减,相邻的数不能相同。

思路:从左往右求一下递增序列,num_left[i]记录前i个数构成的递增序列最大长度。
再从右往左求一遍递增序列,并记录长度,最后遍历记录的两个序列即可。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
//最长单调递增子序列
const int maxn=10005;
const int INF=-0x3f3f3f3f;
int num[maxn];
int num_left[maxn];
int num_right[maxn];
int DP[maxn];
int main()
{
    int N;
    while(scanf("%d",&N)!=EOF)
    {
        for(int i=1;i<=N;i++)
            scanf("%d",&num[i]);
        int len=0;
        DP[0]=INF;
        for(int i=1;i<=N;i++)
        {
            if(num[i]>DP[len])
                DP[++len]=num[i];
            else
            {
                int left=1,right=len;
                while(left<=right)
                {
                    int mid=(left+right)>>1;
                    if(DP[mid]>=num[i])
                        right=mid-1;
                    else
                        left=mid+1;
                }
                DP[left]=num[i];
            }
            num_left[i]=len;
        }
        len=0;
        DP[0]=INF;
        for(int i=N;i>0;i--)
        {
            if(num[i]>DP[len])
                DP[++len]=num[i];
            else
            {
                int left=0,right=len;
                while(left<=right)
                {
                    int mid=(left+right)>>1;
                    if(DP[mid]>=num[i])
                        right=mid-1;
                    else
                        left=mid+1;
                }
                DP[left]=num[i];
            }
            num_right[i]=len;
        }
//        for(int i=1;i<=N;i++)
//            printf("%d*",num_left[i]);
//        printf("\n");
//        for(int i=1;i<=N;i++)
//            printf("%d*",num_right[i]);
//        printf("\n");
        int result=1;
        for(int i=1;i<=N;i++)
            if(result<min(num_left[i],num_right[i]))
                result=min(num_left[i],num_right[i]);
        printf("%d\n",result*2-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值