hdu1059 Dividing _多重部分和问题

 

Dividing

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25426    Accepted Submission(s): 7249

 

 

Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

 

 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

 

 

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.

 

 

Sample Input

 

1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0

 

 

Sample Output

 

Collection #1: Can't be divided. Collection #2: Can be divided.

 

 

 

第一次提交少了个句点,直接wa,真是够冤的



/*
 * 将题目整理一下,其实就是说,有6个不同的数字,每个数字都有ni个,
 * 判断是否可以从这些数字之中选出若干项使它们的和为总价值value的二分之一,
 * (这道题的前提是总价值value能被2整除,如果不能,那就Can't be divided.)
 */

/*
 * 对于多重部分和问题,可以这样考虑(ai:值  ni:每个值的个数 n:数的种数  value:目标和数)
 * dp[i+1][j]:=用前i种数加和得到j时第i种数最多能剩余多少个(不能加和得到j的情况下为-1)
 * 按照如上所述定义递推关系,这样如果前i-1个数加和能得到j的话,第i个数就可以留下ni个。
 * 此外,前i种数加和出j-ai时第i种数还剩下k(k>0)的话,用这i种数加和得到j时,第i种数就剩下k-1个。
 * 所以有如下递推式:
 * 1、dp[i+1][j]=ni (dp[i][j]>=0)
 * 2、dp[i+1][j]=-1  (j<ai||dp[i+1][j-ai]<=0)
 * 3、dp[i+1][j]=dp[i+1][j-ai]-1  (其他)
 * 最终只要看是否满足dp[n][value]>=0就可以知道答案了
 */

 

//
// Created by Admin on 2017/3/20.
//

#include<cstdio>
#include <cstring>

int dp[120010];  //一维数组,将数列重复利用
int main() {
    int n[7], count = 1, value; //value:总价值
    while (scanf("%d%d%d%d%d%d", &n[1], &n[2], &n[3], &n[4], &n[5], &n[6]) != EOF) {
        if (n[1] == 0 && n[2] == 0 && n[3] == 0 && n[4] == 0 && n[5] == 0 && n[6] == 0)break;
        value = n[1] * 1 + n[2] * 2 + n[3] * 3 + n[4] * 4 + n[5] * 5 + n[6] * 6;
        if (value % 2 != 0)printf("Collection #%d:\nCan't be divided.\n\n", count++);
        else {
            value /= 2;
            memset(dp, -1, sizeof(dp));
            dp[0] = 0;
            for (int i = 1; i <= 6; ++i) {  //i代表每种数字的值
                for (int j = 0; j <= value; ++j) {  //j可代表当前总价值
                    if (dp[j] >= 0)
                        dp[j] = n[i];  //n[i]代表每种数字的个数
                    else if (j < i || dp[j - i] <= 0) {
                        dp[j] = -1;
                    }
                    else dp[j] = dp[j - i] - 1;
                }
            }
            if (dp[value] >= 0)printf("Collection #%d:\nCan be divided.\n\n", count++);
            else printf("Collection #%d:\nCan't be divided.\n\n", count++);
        }
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值