hdu1013 Digital Roots _数论-九余数定理

 

Digital Roots

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 76869    Accepted Submission(s): 24008

 

 

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 

 

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 

 

Output

For each integer in the input, output its digital root on a separate line of the output.

 

 

Sample Input

 

24 39 0

 

 

Sample Output

 

6 3

 

/*
 * 九余数定理-定理:一个数被9除得的剩余,等于该数各位数码的和被9除得的剩余
 * 证明略
 */

 

 

//
// Created by Admin on 2017/3/28.
//

#include <cstdio>
#include <cstring>
char s[100010];

int main(){
    int c=1;
    while(scanf("%s",s),s[0]!='0'){
        int len=strlen(s),sum=0;
        for (int i = 0; i < len; ++i) {
            sum+=(s[i]-'0');
            if (sum%9==0)sum=9;
            else sum%=9;
        }
        printf("%d\n",sum);
    }
    return 0
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值