Rescue 优先队列+广搜

Rescue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

给你r为起点,a为终点,#为墙壁,.为路径,遇到x则step+1,作优先队列自定义,优先step短的,然后广搜,每一次访问下一个结点取最小的step返回。

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#define N 205
using namespace std;
int vist[N][N];
char map[N][N];
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
int n,m,k,sum,flag,sx,sy,ex,ey;
struct node
{
    int x,y;
    int step;
    friend bool operator<(node a1,node a2)
    {
        return a2.step<a1.step;
    }
};
int check(int a,int b)
{
    if(a<0||a>=n||b<0||b>=m||map[a][b]=='#'||!vist[a][b])
        return 1;
    return 0;
}
int bfs()
{
    int i;
    priority_queue<node>Q;
    node st,ed;
    st.x=sx;
    st.y=sy;
    st.step=0;
    vist[st.x][st.y]=1;
    Q.push(st);
    while(!Q.empty())
    {
        st=Q.top();
        Q.pop();
        if(st.x==ex&&st.y==ey)
            return st.step;
        for(i=0; i<4; i++)
        {
            ed=st;
            ed.x=st.x+dir[i][0];
            ed.y=st.y+dir[i][1];
            if(check(ed.x,ed.y))
                continue;
            ed.step++;
            if(map[ed.x][ed.y]=='x')
                ed.step++;
            if(vist[ed.x][ed.y]>ed.step)
            {
                vist[ed.x][ed.y]=ed.step;//取最小时间
                Q.push(ed);
            }
        }
    }
    return 0;
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=0; i<n; i++)
        {
            scanf("%s",map[i]);
            for(j=0; map[i][j]; j++)
            {
                if(map[i][j]=='r')
                {
                    sx=i,sy=j;
                }
                else if(map[i][j]=='a')
                {
                    ex=i,ey=j;
                }
            }
        }
        memset(vist,1,sizeof(vist));
        int ans=0;
        ans=bfs();
        if(ans)
            printf("%d\n",ans);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值