poj1018 Communication System

Communication System
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28467 Accepted: 10133
Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.
Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.
Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.
Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110
Sample Output

0.649
找出n个部件的生产公司,要求B/P最大,其中B为取到的公司生产出来的最小带宽,P代表取出n件物品的总价值。
统计最小带宽和最大带宽,枚举最大带宽,然后统计最小的价值和

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#define INF 0xffff
using namespace std;

int main()
{
    int B[110][110];
    int P[110][110];
    int num[110];
    int n;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        //int n;
        scanf("%d",&n);
        int minn=INF;
        int maxn=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&num[i]);
            for(int j=1; j<=num[i]; j++)
            {
                scanf("%d %d",&B[i][j],&P[i][j]);
                if(B[i][j]<minn)
                    minn=B[i][j];
                if(B[i][j]>maxn)
                    maxn=B[i][j];
            }
        }///选出宽带 最大最小值
        //cout<<minn<<' '<<maxn<<endl;
        double ans=0.0;
        for(int i=minn; i<=maxn; i++) ///枚举宽带
        {
            int sum=0;
            for(int j=1; j<=n; j++)
            {
                int minp=INF;
                for(int k=1; k<=num[j]; k++)
                {
                    if(B[j][k]>=i&&P[j][k]<minp)
                    {
                        minp=P[j][k];
                    }
                }
                sum+=minp;
            }
            if(i*1.0/sum>ans)
                ans=i*1.0/sum;
        }
        printf("%.3f\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值