北大oj1018——Communication System

Communication System

Time Limit: 1000MS Memory Limit: 10000K

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649

dp
建立二维数组

#include<iostream>
#include<algorithm>
#include <iomanip>
using namespace std;

int main() {
    int t;
    cin >> t;
    int bp[101][501];
    for (int x = 1; x <= t; x++) {
        memset(bp, 0, sizeof(bp));
        int n;
        cin >> n;
        for (int y = 1; y <= n; y++) {
            int i;
            cin >> i;
            int bi, pi;
            for (int k = 0; k < i; k++) {
                cin >> bi >> pi;
                if (y == 1) {
                    if (bp[1][bi] == 0 || pi < bp[1][bi]) {
                        bp[1][bi] = pi;
                    }
                }
                else {
                    for (int t = 0; t <= 500; t++) {
                        if (bp[y - 1][t] > 0) {
                            int minB = min(t, bi);
                            if (bp[y][minB] == 0 || pi + bp[y - 1][t] < bp[y][minB]) {
                                bp[y][minB] = pi + bp[y - 1][t];
                            }
                        }
                    }
                }
            }
        }
        double maxBP = 0;
        for (int y = 1; y <= 500; y++) {
            if (bp[n][y] == 0) {
                continue;
            }
            double tempBP = 1.0 * y / bp[n][y];
            if (tempBP > maxBP) {
                maxBP = tempBP;
            }
        }

        //printf("%.3lf\n", maxBP);
        cout << setiosflags(ios::fixed) << setprecision(3) << maxBP << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

椰子糖莫莫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值