POJ-2253-Frogger(最短路)

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

代码两个:因为可以互相跳来跳去,所以跟单源不太一样,距离不仅是d[i][j]也是d[j][i]的
第一个要比第二个快,第一个48ms 第二个63ms ,然后这题得用G++,不能用C++,因为C++会出现编译错误,主要因为sqrt函数在C++中分的太清楚了,有三个重载会不明确

代码一如下:

#pragma warning(disable:4996)
#define K(a)       scanf("%d", &a)
#define KK(a,b)    scanf("%d %d", &a, &b)
#define KKK(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define kd          printf
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#include<iomanip>
#include<iostream>
using namespace std;

const int MAXX = 205;  

double d[MAXX][MAXX];
int a[MAXX], b[MAXX];
int V;
int main()
{
	int res = 0;
	while (K(V))
	{
		if (V == 0)break;
		memset(d, 0, sizeof d);
		for (int i = 0; i < V; i++)
			KK(a[i], b[i]);

		for (int i = 0; i < V; i++)                    //i可以跳j,j也可以跳i,将给出的所有点之间的所有距离都得求出来!!
			for (int j = i + 1; j < V; j++)
			{
				d[i][j] = d[j][i] = sqrt((a[i] - a[j])*(a[i] - a[j]) + (b[i] - b[j])*(b[i] - b[j]));
			}
		for (int k = 0; k < V; k++)
			for (int i = 0; i < V; i++)
				for (int j = i+1; j < V; j++)           // i,j,k三点的三角恋
				{
					if (d[i][j] > d[i][k] && d[i][j] > d[k][j])           //从i到j肯定可以跳,也肯定可以借助某个k,比较i-j距离与i-k,k-j距离把其中一个锁定!
						if (d[i][k] > d[k][j])
						{
							d[i][j]= d[j][i] = d[i][k];          //这里是和第二个的唯一区别
						}
						else d[i][j] = d[j][i] = d[k][j];
				}


		cout << "Scenario #" << ++res << endl;
		cout << "Frog Distance = " << setprecision(3) << fixed << d[0][1] << endl;
		cout << endl;
	}
	
}

注意观察第二个和第一个的区别

代码如下:

#pragma warning(disable:4996)
#define K(a)       scanf("%d", &a)
#define KK(a,b)    scanf("%d %d", &a, &b)
#define KKK(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define kd          printf
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#include<iomanip>
#include<iostream>
using namespace std;

const int INF = 9999999;
const int MAXX = 205;  

double d[MAXX][MAXX];
int a[MAXX], b[MAXX];
int V;
int main()
{
	int res = 0;
	while (K(V))
	{
		if (V == 0)break;
		memset(d, 0, sizeof d);
		for (int i = 0; i < V; i++)
			KK(a[i], b[i]);

		for (int i = 0; i < V; i++)                    //i可以跳j,j也可以跳i,将给出的所有点之间的所有距离都得求出来!!
			for (int j = i + 1; j < V; j++)
			{
				d[i][j] = d[j][i] = sqrt((a[i] - a[j])*(a[i] - a[j]) + (b[i] - b[j])*(b[i] - b[j]));
			}
		for (int k = 0; k < V; k++)
			for (int i = 0; i < V; i++)
				for (int j = 0; j < V; j++)           // i,j,k三点的三角恋
				{
					if (d[i][j] > d[i][k] && d[i][j] > d[k][j])           //从i到j肯定可以跳,也肯定可以借助某个k,比较i-j距离与i-k,k-j距离把其中一个锁定!
						if (d[i][k] > d[k][j])
						{
							d[i][j] = d[i][k];
						}
						else d[i][j] = d[k][j];
				}


		cout << "Scenario #" << ++res << endl;
		cout << "Frog Distance = " << setprecision(3) << fixed << d[0][1] << endl;
		cout << endl;
	}
	
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wujiekd

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值