HDU 1016 Prime Ring Problem(深度优先搜索)

61 篇文章 0 订阅

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39311 Accepted Submission(s): 17325

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source
Asia 1996, Shanghai (Mainland China)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016

本宝宝一向是不擅长做深搜题目的,宝宝这次豁出去了,鼓足勇气后,,笨宝宝冲向了本道搜索题。。
下面笨宝宝把代码给大家附上。。。。真的没啥好说的。。
就是一直递推找到符合题目的解。。。

AC代码。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int primejudge(int n)
{
    for(int i=2; i<=sqrt(n); i++)
        if(n%i==0)
            return 0;
    return 1;
}

int a[25],n;
int book[25];
int k;
void dfs(int num,int k)
{
    if(k==n)
    {
        if(primejudge(a[0]+a[n-1]))
        {
            for(int i=0; i<n-1; i++)
            {
                printf("%d ",a[i]);
            }
            printf("%d\n",a[n-1]);
        }
        return;
    }
    for(int m=2; m<=n; m++)
    {
        if(book[m]==0)
        {
            if(primejudge(a[num-1]+m))
            {
                a[num]=m;
                book[m]=1;
                dfs(num+1,k+1);
                book[m]=0;
            }
        }
    }
    return ;
}

int main()
{
    int j=0;
    while(~scanf("%d",&n))
    {
        memset(book,0,sizeof(book));
        j++;
        printf("Case %d:\n",j);
        a[0]=1;
        book[1]=1;
        dfs(1,1);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值