HDU 5323 Solve this interesting problem(DFS反构造线段树)

61 篇文章 0 订阅
22 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=5323
Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2931 Accepted Submission(s): 910
Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values: Lu and Ru.
- If Lu=Ru, u is a leaf node.
- If Lu≠Ru, u has two children x and y,with Lx=Lu,Rx=⌊Lu+Ru2⌋,Ly=⌊Lu+Ru2⌋+1,Ry=Ru.
Here is an example of segment tree to do range query of sum.
这里写图片描述
Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node’s value Lroot=0 and Rroot=n contains a node u with Lu=L and Ru=R.

Input
The input consists of several test cases.
Each test case contains two integers L and R, as described above.
0≤L≤R≤109
LR−L+1≤2015

Output
For each test, output one line contains one integer. If there is no such n, just output -1.

Sample Input
6 7
10 13
10 11

Sample Output
7
-1
12

思路:做这个题需要有一定的线段树的基础,知道线段树的特性,线段树的特性就是左区间比右区间少1,知道了这个特性,剩下的就很简单了。
下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define INF 0x3fffffff
#define ll long long
ll ans;

void dfs(ll l,ll r)
{
    if(l<0) return ;
    if(l==0)
    {
        ans=min(ans,r);    
        return;
    }
    if(r-l+1-l>2)//剪枝
        return ;
    ll len=r-l+1;
    dfs(l-len,r);
    dfs(l-len-1,r);
    dfs(l,r+len);
    if(l!=r)
        dfs(l,r+len-1);
}

int main()
{
    ll l,r;
    while(~scanf("%I64d%I64d",&l,&r))
    {
        ans=INF;
        dfs(l,r);
        if(ans==INF)
            printf("-1\n");
        else
            printf("%I64d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值