题目链接:
http://poj.org/problem?id=3660
Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10104 Accepted: 5711
Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
- Line 1: Two space-separated integers: N and M
- Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
- Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
Source
USACO 2008 January Silver
【题意】共有n个奶牛,m个相对关系,问你有多少奶牛的相对关系是确定的。
【分析】求多少个奶牛的关系是确定的,即求某个奶牛与剩下的n-1的奶牛的关系是不是确定的,如果确定,那么这个奶牛的关系是确定的。下面用floyed算法求一下传递闭包就OK了。
下面是是AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 105
int a[105][105];
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
memset(a,0,sizeof(a));
int u,v;
for(int i=1;i<=m;i++)
{
scanf("%d%d",&u,&v);
a[u][v]=1;
}
for(int k=1;k<=n;k++)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(a[i][k]==1&&a[k][j]==1)
{
a[i][j]=1;
}
}
}
}
int sum=0;
for(int i=1;i<=n;i++)
{
int flag=0;
for(int j=1;j<=n;j++)
{
if(i==j)continue;//自己与自己不需要判断
if(a[i][j]==0&&a[j][i]==0)
{
flag=1;
break;
}
}
if(!flag)
{
sum++;
}
}
printf("%d\n",sum);
}
return 0;
}