uva 129 Krypton Factor

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''.
For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:
BB
ABCDACABCAB
ABCDABCD
Some examples of hard sequences are:
D
DC
ABDAB
CBABCBA
Input and Output
In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.
For example, with L = 3, the first 7 hard sequences are:
A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA
As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.
Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be
ABAC ABA
7
Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.
Sample Input
30 3
0 0
Sample Output
ABAC ABCA CBAB CABA CABC ACBA CABA

28

书上的原题:留给思路不是很清晰的自己:

<span style="font-family:Arial;">#include <iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int n,L,tot;
int a[100];
int dfs(int cur)//寻找到了第cur个字母,买没有寻找,或者正要寻找
{
    if(tot++==n){//注意这是tot不是cur,tot是记录目前是第tot小的序列,每做一次dfs就是一次序列,cur记录的是序列的长度,不要搞混!
                 //如果已经是第n小的序列了就输出,这个序列是是一个dfs寻找出来的
       for(int i=0;i<cur;i++){//cur是当前需要寻找的一个字母所以不要输出
            if(i%64==0 && i) printf("\n");          //若16组后要先换行
            else if(i%4==0 && i) printf(" ");       //每4个用空格隔开
            printf("%c",a[i]+'A');
        }
        printf("\n");
        printf("%d\n",cur);
        return 1;
    }else{
        for(int i=0;i<L;i++)
        {
            a[cur]=i;
            int ok=1;
            for(int l=1;l*2<=cur+1;l++)
            {
                int eq=1;
                for(int k=0;k<l;k++)
                {
                    if(a[cur-k]!=a[cur-k-l]) {eq=0;break;}
                }
                if(eq) {ok=0;break;}
            }
            if(ok) if(dfs(cur+1)) return 1;//寻找下一个字母
        }
    }
    return 0;
}
int main()
{
    while(scanf("%d %d",&n,&L)!=EOF&&(n+L))
    {
        memset(a,0,sizeof(a));
        tot=0;
        dfs(0);
    }
    return 0;
}
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值