UVA-129 Krypton Factor

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such a no ccurrence will be called“easy”. Other sequences will be called “hard”. For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are: • BB • ABCDACABCAB • ABCDABCD Some examples of hard sequences are: • D • DC • ABDAB • CBABCBA In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines from standard input and will write to standard output.

Input
Each input line contains integers n and L (in that order),where n > 0 and L is in the range 1 ≤ L ≤ 26. Input is terminated by a line containing two zeroes.

Output
For each input line prints out he n-th hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (Alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is ‘A’. You may assume that for given n and L there do exist at least n hard sequences. As such a sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.
Your program may assume a maximum sequence length of 80. For example, with L = 3, the first 7 hard sequences are: A AB ABA ABAC ABACA ABACAB ABACABA

Sample Input
7 3
30 3
0 0

Sample Output
ABAC ABA
7
ABAC ABCA CBAB CABA CABC ACBA CABA
28

分析:dfs回溯。从当前字符串的尾部,判断是否有重复连续子串,长度从1开始。不需要将整个字符串全部检查一遍。

Source:

#include<stdio.h>
#include<string.h>
int n,l,cnt;
char s[100];
int dfs(int cur)
{
    int i,j,k,equal,ok;
    if(cnt++==n)                        /*计数器*/
    {
        for(i=0;i<cur;i++)
        {
            if(i!=0&&i%4==0)            /*注意格式*/
                if(i!=0&&i%64==0)
                    printf("\n");
                else
                    printf(" ");
            printf("%c",'A'+s[i]);
        }
        printf("\n%d\n",cur);
        return 0;
    }
    else
    {
        for(i=0;i<l;i++)
        {
            s[cur]=i;
            ok=1;
            for(j=1;j*2<=cur+1;j++)           /*判断是否有连续子串*/
            {
                equal=1;
                for(k=0;k<j;k++)
                    if(s[cur-k]!=s[cur-k-j])
                    {
                        equal=0;
                        break;
                    }
                if(equal)
                {
                    ok=0;
                    break;
                }
            }
            if(ok)
            {
                if(!dfs(cur+1))
                    return 0;
            }
        }
    }
    return 1;
}
int main()
{
    int t;
    while(scanf("%d%d",&n,&l)!=EOF)
    {
        if(n==0&&l==0)
            return 0;
        memset(s,0,sizeof(s));
        cnt=0;
        t=dfs(0);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值