POJ 2398 Toy Storage [叉积判断+二分查找]【计算几何】

题目链接:http://poj.org/problem?id=2398

Toy Storage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4962 Accepted: 2950

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza’s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

这里写图片描述

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.
Output

For each box, first provide a header stating “Box” on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1


没做过poj 2318的建议先做一下 跟本题是差不多的 但稍微简单些 http://poj.org/problem?id=2398

题目大意: 有一个方盒子 有N个板隔开 分成N+1个区域
又给了M个玩具的坐标 问你有N个玩具(忽略玩具体积)的区域(不能恰好在区域内)有几个

解题思路: 每相邻的两个板看成两个向量 分别求其与其中一点和玩具坐标的叉积 如果两叉积的乘积<0 就说明这个玩具坐标点在一个板的右边 一个板的左边

因为数据量比较大 可以把板和方盒的两边记录下来 然后二分 道理是一样的

上述就能记录下来每个区域有几个玩具
所以有N个玩具的区域有几个 就不用赘述了…


附本题代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int num[5005],sum[5005];
int n,m;

struct point
{
    int x,y;
} q;
struct node
{
    point pu,pl;
}ban[5005];
int mul(point p1,point p2,point p3)
{
    return (p2.x-p1.x)*(p3.y-p1.y)-(p3.x-p1.x)*(p2.y-p1.y);
}

int cmp(node A,node B)
{
    /*
    if(A.pu.x==B.pu.x)
        return A.pl.y<B.pl.y;
    else
    */
    return A.pu.x<B.pu.x;
}

void Besearch(point x)
{
    int l=0,r=n+1,ans;
    while(l<=r)
    {
        int mid=(l+r)/2;
        if(mul(x,ban[mid].pu,ban[mid].pl)<0)
        {
            ans=mid;
            r=mid-1;
        }
        else
            l=mid+1;
    }
    num[ans-1]++;
}

int main()
{
    int x1,x2,y1,y2;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        memset(num,0,sizeof(num));
        memset(sum,0,sizeof(sum));
        scanf("%d %d %d %d %d ",&m,&x1,&y1,&x2,&y2);

        ban[0].pu.x = x1,ban[0].pu.y=y1;
        ban[0].pl.x = x1,ban[0].pl.y=y2;
        for(int i=1; i<=n; i++)
        {
            scanf("%d %d",&ban[i].pu.x,&ban[i].pl.x);
            ban[i].pu.y=y1,ban[i].pl.y=y2;
        }
        ban[n+1].pu.x = x2,ban[n+1].pu.y=y1;
        ban[n+1].pl.x = x2,ban[n+1].pl.y=y2;
        sort(ban,ban+n+1,cmp);
        for(int i=0; i<m; i++)
        {
            scanf("%d %d",&q.x,&q.y);
            Besearch(q);
        }
        printf("Box\n");
        int maxi=-100;
        for(int i=0;i<=n;i++)
        {
            sum[num[i]]++;
            maxi=max(maxi,sum[num[i]]);
        }
        for(int i=1; i<=maxi; i++)
            if(sum[i])
            printf("%d: %d\n",i,sum[i]);

    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值