1114. Family Property (25) <并查集,set>

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
一行纪录所有节点的父亲都是find(id) 构造数组

房产和面积绑定给id

将所有纪录放在set里面,遍历,找到所有的父亲节点。

并且计算总的房产和面积

最后在遍历找到最小的id,排序输出


#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<stack>
using namespace std;
int k; 
int father[10000]; 
int sum[10000]={0},area[10000]={0}; 
int fa[10000]={0}; 
typedef struct node{
	int id,sum;
	double a_set,a_area; 
}node;
int find(int x){
	if(x==father[x]) return x;
	return father[x]=find(father[x]);
}
bool cmp(node n1,node n2){
	if(n1.a_area!=n2.a_area){
		return n1.a_area>n2.a_area;
	} 
	return n1.id<n2.id; 
}
int main(){
	cin>>k;
	set<int> nu; 
	for(int i=0;i<10000;i++) father[i]=i;
	for(int i=0;i<k;i++){
		int id,f,m;
		scanf("%d%d%d",&id,&f,&m);
		int fz=id; 
		nu.insert(id);
		id=find(id);
		if(f!=-1) {
			father[find(f)]=id;
			nu.insert(f);
		}
		
		if(m!=-1){
			father[find(m)]=id;
			nu.insert(m);
		} 
		int num;
		scanf("%d",&num);
		for(int i=0;i<num;i++){
			int chi;
			scanf("%d",&chi);
			nu.insert(chi);
			father[find(chi)]=id;
		}
		int M_estate,Area;
		scanf("%d%d",&M_estate,&Area);
		sum[fz]=M_estate;
		area[fz]=Area;
	}
	set<int> s;
	for(set<int>::iterator it=nu.begin();it!=nu.end();it++){
		int num=find(*it);
		if(*it!=num) {
		   area[num]+=area[*it];
		   sum[num]+=sum[*it]; 	
		}
		
		fa[num]++;
		s.insert(num); 
	}
	node no[1001];
	int cnt=0;
	int v[10000]={0};
	for(set<int>::iterator it=nu.begin();it!=nu.end();it++){
		int fz=find(*it);
		if(v[fz]==0&&s.find(fz)!=s.end()){
			v[fz]=1; 
			no[cnt].id=*it;
			no[cnt].sum=fa[fz];
			no[cnt].a_set=1.0*sum[fz]/fa[fz];
			no[cnt].a_area=1.0*area[fz]/fa[fz];
			cnt++;
		}
	}	 
	/*for(int i=0;i<=9999;i++){ //这点是想到set容器默认从小到大排序,这样会浪费时间,直接遍历set容器寻找最小id
		int fz=find(i);
		if(v[fz]==0&&s.find(fz)!=s.end()){
			v[fz]=1; 
			no[cnt].id=i;
			no[cnt].sum=fa[fz];
			no[cnt].a_set=1.0*sum[fz]/fa[fz];
			no[cnt].a_area=1.0*area[fz]/fa[fz];
			cnt++;
			//printf("%04d %d %.3f %.3f\n",i,fa[fz],1.0*sum[fz]/fa[fz],1.0*area[fz]/fa[fz]);
		}
	} */
	sort(no,no+cnt,cmp);
	cout<<cnt<<endl;
	for(int i=0;i<cnt;i++){
		printf("%04d %d %.3f %.3f\n",no[i].id,no[i].sum,no[i].a_set,no[i].a_area);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值