PAT A1114 Family Property (25分)——图的遍历

1、题目

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child
​1
​​ ⋯Child
​k
​​ M
​estate
​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child
​i
​​ 's are the ID’s of his/her children; M
​estate
​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG
​sets
​​ AVG
​area
​​

where ID is the smallest ID in the family; M is the total number of family members; AVG
​sets
​​ is the average number of sets of their real estate; and AVG
​area
​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

2、我的思路

1、用无向图来表示各个成员之间的关系(-1表示空节点,不加入图);2、结构体数组来存储每个点的点权(sets,area);3、DFS遍历整个图,连通块数即为家庭数,计算每个连通块的节点数(即成员数),点权之和,记录最小id;4、结构体数组ans[] 记录每个连通块的最小id,点数,平均sets,平均area;5、按输出要求对ans[]排序,然后顺序输出。

3、我的代码

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int INF=0x7fffffff; 
const int MAXN=10000;
vector<int> G[MAXN],ids;//ids存所有节点id,以便遍历 
bool vis[MAXN]={false};
struct Node
{
	double sets=0;
	double area=0;
}node[MAXN];
//遍历连通块时需要记录的信息
double tot_sets=0,tot_area=0;
int memberNum=0;
int minId=INF;
struct Ans
{
	int id;
	int mN;
	double ave_sets;
	double ave_area;
}ans[1002];
bool cmp(Ans a,Ans b)
{
	if(a.ave_area!=b.ave_area)
		return a.ave_area>b.ave_area;
	else
		return a.id<b.id;
}
void DFS(int s)
{
	vis[s]=true;
	if(s<minId)
	{
		minId=s;
	}
	tot_sets+=node[s].sets;
	tot_area+=node[s].area;
	memberNum++;
	for(int i=0;i<G[s].size();i++)
	{
		int child=G[s][i];
		if(vis[child]==false)
		{
			DFS(child);
		}
	}
}

int main()
{
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		int id,fa,ma,k;
		scanf("%d%d%d%d",&id,&fa,&ma,&k);
		ids.push_back(id); 
		if(fa!=-1)
		{
			G[id].push_back(fa);
			G[fa].push_back(id);
		}
		if(ma!=-1)
		{
			G[id].push_back(ma);
			G[ma].push_back(id);
		}
		if(k>0)
		{
			for(int j=0;j<k;j++)
			{
				int child;
				scanf("%d",&child);
				G[id].push_back(child);
				G[child].push_back(id);
			}
		}
		scanf("%lf%lf",&node[id].sets,&node[id].area);
	}
	int ansNum=0;
	for(int i=0;i<ids.size();i++)
	{
		int v=ids[i];
		if(vis[v]==false)
		{
			DFS(v);
			ans[ansNum].ave_sets=tot_sets/memberNum;
			ans[ansNum].ave_area=tot_area/memberNum;
			ans[ansNum].id=minId;
			ans[ansNum].mN=memberNum;
			ansNum++;
			tot_area=0;tot_sets=0;
			memberNum=0;
			minId=INF;
		}
	}
	sort(ans,ans+ansNum,cmp);
	printf("%d\n",ansNum);
	for(int i=0;i<ansNum;i++)
	{
		printf("%04d %d %.3f %.3f\n",ans[i].id,ans[i].mN,ans[i].ave_sets,ans[i].ave_area);
	}
	return 0;
} 


4、测试结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值