(BFS)Rescue--HDOJ

Rescue
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1425 Accepted Submission(s): 558

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

Process to the end of the file.

Output

        For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8

.#####.

.a#..r.

..#x…

..#..#.#

…##..

.#……
……..

Sample Output

13

Author
CHEN, Xue

Source
ZOJ Monthly, October 2003

Recommend
Eddy

总结:
需要注意的是 朋友有很多个,从每个朋友到达a的时间中取最短的一个,那么也就是说从a开始走,利用BFS遇到的第一个朋友,就是时间最短的路线

#include<iostream>
#include<string.h>
#include<string>
#include<stdio.h>
#include<algorithm>
#include<queue>
#include<math.h>
#define PI acos(-1.0)
#define eps 0.00000001

using namespace std;

typedef struct Node
{
    int x,y,ti;
}Node;

char mp[205][205];
Node fri[205];
int vis[205][205];
int dirx[4] = {1,-1,0,0};
int diry[4] = {0,0,-1,1};
int tarx,tary,n,m;

int BFS(int xx,int yy)
{
    queue<Node> q;
    Node t;
    t.x = xx,t.y = yy,t.ti=0;//这里的时间
    vis[t.x][t.y] = 1;
    q.push(t);
    memset(vis,0,sizeof(vis));
    while(!q.empty())
    {
        Node tmp = q.front();
        q.pop();
        for(int i=0; i<4; ++i)
        {
            int xx = tmp.x + dirx[i];
            int yy = tmp.y + diry[i];
            if(xx<0||xx==n||yy<0||yy==m) continue;
            if(mp[xx][yy] == '#') continue;
            if(vis[xx][yy]) continue;
            Node nxt;
            nxt.x = xx,nxt.y = yy;
            if(mp[xx][yy] == '.')
                nxt.ti = tmp.ti + 1;
            else if(mp[xx][yy] == 'x')
                nxt.ti = tmp.ti + 2;
            else if(mp[xx][yy] == 'r')
            {
                nxt.ti = tmp.ti + 1;
                return nxt.ti;
            }
            vis[xx][yy] = 1;
            q.push(nxt);
        }
    }
    return 999999;
}

int main(void)
{
 //   freopen("in.txt","r",stdin);

    while(scanf("%d %d",&n,&m) != EOF)
    {
        int numFri=0;
        for(int i=0; i<n; ++i)
        for(int j=0; j<m; ++j)
        {
            cin >> mp[i][j];
            if(mp[i][j] == 'a')
            {
                tarx = i;
                tary = j;
            }
        }
        int ans = 999999;
        ans = BFS(tarx,tary);

        if(ans == 999999)
            cout << "Poor ANGEL has to stay in the prison all his life."<<endl;
        else
            cout << ans <<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值