poj 2398 Toy Storage (计算几何)

A - Toy Storage
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1
题意:poj2318的升级版,题意是一样的,输入输出不同。将poj2318的代码稍加修改即可。
题解:输入是乱序,需要排一下序。输出时先输出一个Box换行,然后输出区间中含1个玩具的
   有多少个,含2个玩具的有多少个……一直到含m个玩具的有多少个,如果含i个玩具的区
   间数为0,不做如何输出。输出格式见样例。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long ll;
struct point{
    ll x,y;
};
struct Line{
    point a,b;
}line[5005];
ll cnt[5005],ans[5005];
bool cmp(Line r1,Line r2)
{
    return r1.a.x<r2.a.x;//注意符号
}
ll Multi(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
void s(point a,ll n)
{
    ll l=0,r=n-1,mid;
    while(l<r)
    {
        mid=(l+r)>>1;
        if(Multi(a,line[mid].a,line[mid].b)>0) l=mid+1;
        else r=mid;
    }
    if(Multi(a,line[l].a,line[l].b)<0)
        cnt[l]++;
    else
        cnt[l+1]++;
}
int main()
{
    ll n,m,x1,y1,x2,y2;
    ll i,t1,t2;
    point a;
    while(cin>>n&&n)
    {
        cin>>m>>x1>>y1>>x2>>y2;
        for(int i=0;i<n;i++)
        {
            cin>>t1>>t2;
            line[i].a.x=t1;
            line[i].a.y=y1;
            line[i].b.x=t2;
            line[i].b.y=y2;
        }
        sort(line,line+n,cmp);
        memset(cnt,0,sizeof(cnt));
        memset(ans,0,sizeof(ans));
        for(int i=0;i<m;i++)
        {
            cin>>a.x>>a.y;
            s(a,n);
        }
        for(int i=0;i<=n;i++)
        {
            if(cnt[i])
                ans[cnt[i]]++;
        }
        cout<<"Box"<<endl;
        for(int i=1;i<=m;i++)
            if(ans[i])
        cout<<i<<": "<<ans[i]<<endl;
    }
    return 0;
}
 
   

 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值