Tiling

E - Tiling
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

这个题呢规律还不是很难找的。

可以想一下新加上的N要么什么也不做(此时呢就是a[n-1]);

要么就是和前面的一条合并,合并的时候无非三种:

1.合并起来一个大的

2.合并起来横着两个

3.合并起来竖着两个  (这个地方要想一想,跟什么也不做的时候会不会重复)答案是肯定的。因为你为长条的时候前面一个存在也是单个长条的情况!所以就是2*a[n-2];


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <queue>
#include <vector>
using namespace std;
void sum(char *a,char *b,char *c)
{
    int l1=strlen(a);
    int l2=strlen(b);
    int cnt=0;
    int x=0;
    int i=0,j=0;
    while(i<l1&&j<l2)
    {
        x+=(a[i]-'0'+b[j]-'0');
        c[cnt++]=x%10+'0';
        x/=10;
        i++;
        j++;
    }
    while(i<l1)
    {
        x+=(a[i]-'0');
        c[cnt++]=x%10+'0';
        x/=10;
        i++;
    }
    while(j<l2)
    {
        x+=(b[j]-'0');
        c[cnt++]=x%10+'0';
        x/=10;
        j++;
    }
    while(x)
    {
        c[cnt++]=x%10+'0';
        x/=10;
    }
    c[cnt]='\0';
}
int main()
{
    int i; char a[302][100];
    int n;
    char c[100];
    strcpy(a[0],"1");
    strcpy(a[1],"1");
    strcpy(a[2],"3");
        for(i=3;i<=270;++i)
        {
            sum(a[i-2],a[i-2],c);
            sum(a[i-1],c,a[i]);
        }
    while(~scanf("%d",&n))
    {
           for(i=strlen(a[n])-1;i>=0;--i)printf("%c",a[n][i]);
           printf("\n");
    }
    return 0;
}







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值