Radar Installation

D - Radar Installation
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

这个题就是让你在X轴上找站,用最少的站数来包裹所有的点,这个题想一想差不多是个贪心。

把每个点的能到达的最远距离(d^2-y^2)的左端点b和右端点e计算并储存出来,只要站在b~e之间就可以包裹起来。

在这里我们按照点的左端点从小到大排序。

总的思路就是以第一个点的右端点为站点。只要下一个点能被这个点包裹进去就继续,包裹不了就重新加一个站。

新加的点3种情况e<站点    b<=站点<=e 站点<b。

画个图


按照这个来看黄色的点是第一个然后是绿色,蓝色。此时应该选绿色(也就是最小的)为什么?因为绿色都可以把他们包裹起来而黄色不能。所以e如果更小应该更新。

当e>=绿色点时呢?我们可以看到紫色的b在绿色左边没问题,而粉色在右边显然不行此时应当加一个站点了,更新为粉色的e,之后就是重复上面的了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <set>
#include <cmath>
#include <algorithm>
using namespace std;
const int inf=0x3f3f3f;
int n,d;
struct node
{
    double b,e;
}a[1024];
int cmp(node a,node b)
{
    return a.b<b.b;
}
int main()
{
    int x,y;
    int i;
    int t=0;
    while(~scanf("%d%d",&n,&d))
   {
       if(n==0&&d==0)break;
       t++;
       int h=1,f=1;
    for(i=0;i<n;++i)
    {
        scanf("%d%d",&x,&y);
        a[i].b=x-sqrt(d*d*1.0-y*y);
        a[i].e=x+sqrt(d*d*1.0-y*y);
        if(abs(y)>d)f=0;
    }
    if(!f)printf("Case %d: -1\n",t);
    else
    {
        sort(a,a+n,cmp);
        double l=a[0].e;
        for(i=1;i<n;++i)
        {
            if(a[i].e<l)
            {
                l=a[i].e;
            }
            else  if(a[i].b>l)
            {
                h++;
                l=a[i].e;
            }
        }
        printf("Case %d: %d\n",t,h);
    }


   }

    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值