All in All
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 31754 | Accepted: 13179 |
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter
Sample Output
Yes No Yes No比较简单,只要第二个串中第一个串的字符相对顺序不变就可以。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
using namespace std;
int main()
{
char s[100005],t[100005];
while(~scanf("%s%s",s,t))
{
int i,j;
j=0;
int l=strlen(t);
for(i=0;i<l;++i)
{
if(t[i]==s[j])
{
j++;
if(s[j]=='\0')break;
}
}
if(i<l)printf("Yes\n");
else printf("No\n");
}
return 0;
}
直接走一遍就可以了~