poj3026 Borg Maze

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12676 Accepted: 4139

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11
这个题说的是S要和所有的A汇合,最少要走多少的步数。实际上就是一个bfs+最小生成树。

我们先找出,S和A点之间的最短距离作为两点的权值,然后求一个最小生成树,表示弄了一个下午QAQ。

先是注意字符串里面是有空格的,不能用scanf读取,用gets;

然后还是一直TLE,之后想了想,最多能够有2500个点的,如果每两两点之间都去bfs一下,复杂度确实太高了QAQ,看了一下别人,猛然醒悟,确实可以每个点只需要一次bfs就行了,感觉被自己蠢哭了,每个点遍历一次,这样这个点到其余点之间的最短距离都可以bfs出来的,这个只需要加一个标记数组就可以,只要搜到了点就附上相应的权值即可QAQ


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
const int inf=0x3f3f3f;
int n,m;
int vis[52][52];
char s[52][52];
int tu[2520][2520];
int dx[4]={-1,1,0,0};
int dy[4]={0,0,1,-1};
int Map[52][52];
struct node
{
    int x,y,step;
};
void bfs(int sx,int sy)
{
    memset(vis,0,sizeof(vis));
    int i;
    node k,t;
    k.x=sx;
    k.y=sy;
    k.step=0;
    queue<node>q;
    q.push(k);
    vis[k.x][k.y]=1;
    int sum=0;
    while(!q.empty())
    {
        k=q.front();
        q.pop();
        if(Map[k.x][k.y])tu[Map[sx][sy]][Map[k.x][k.y]]=k.step;
        for(i=0;i<4;++i)
        {
            int x=k.x+dx[i];
            int y=k.y+dy[i];
            if(x>=0&&x<n&&y>=0&&y<m&&!vis[x][y]&&s[x][y]!='#')
            {
                vis[x][y]=1;
                t.x=x;
                t.y=y;
                t.step=k.step+1;
                q.push(t);
            }
        }
    }
}
int v[2520],dis[2520];
void prim(int n)
{
    int i,j;

    for(i=1;i<=n;++i)
    {
        dis[i]=tu[1][i];
        v[i]=0;
    }
    v[1]=1;
    int sum=0,mm,pos;
    for(i=0;i<n-1;++i)
    {
         mm=inf;
         for(j=1;j<=n;++j)
         {
             if(!v[j]&&dis[j]<mm)
             {
                 mm=dis[j];
                 pos=j;
             }
         }
         v[pos]=1;
         sum+=mm;
         for(j=1;j<=n;++j)if(!v[j]&&dis[j]>tu[pos][j])dis[j]=tu[pos][j];
    }
    printf("%d\n",sum);
}

int main()
{
    int t ,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d\n",&m,&n);
        int cnt=0;
        for(i=0;i<n;++i)
        {
            gets(s[i]);
            for(j=0;j<m;++j)
            {
                if(s[i][j]=='S'||s[i][j]=='A')
                {
                    Map[i][j]=++cnt;
                }
                else Map[i][j]=0;
            }
        }
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
        {
            if(Map[i][j])bfs(i,j);
        }
        prim(cnt);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
4S店客户管理小程序-毕业设计,基于微信小程序+SSM+MySql开发,源码+数据库+论文答辩+毕业论文+视频演示 社会的发展和科学技术的进步,互联网技术越来越受欢迎。手机也逐渐受到广大人民群众的喜爱,也逐渐进入了每个用户的使用。手机具有便利性,速度快,效率高,成本低等优点。 因此,构建符合自己要求的操作系统是非常有意义的。 本文从管理员、用户的功能要求出发,4S店客户管理系统中的功能模块主要是实现管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理,用户客户端:首页、车展、新闻头条、我的。门店客户端:首页、车展、新闻头条、我的经过认真细致的研究,精心准备和规划,最后测试成功,系统可以正常使用。分析功能调整与4S店客户管理系统实现的实际需求相结合,讨论了微信开发者技术与后台结合java语言和MySQL数据库开发4S店客户管理系统的使用。 关键字:4S店客户管理系统小程序 微信开发者 Java技术 MySQL数据库 软件的功能: 1、开发实现4S店客户管理系统的整个系统程序; 2、管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理等。 3、用户客户端:首页、车展、新闻头条、我的 4、门店客户端:首页、车展、新闻头条、我的等相应操作; 5、基础数据管理:实现系统基本信息的添加、修改及删除等操作,并且根据需求进行交流信息的查看及回复相应操作。
现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本微信小程序医院挂号预约系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此微信小程序医院挂号预约系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。微信小程序医院挂号预约系统有管理员,用户两个角色。管理员功能有个人中心,用户管理,医生信息管理,医院信息管理,科室信息管理,预约信息管理,预约取消管理,留言板,系统管理。微信小程序用户可以注册登录,查看医院信息,查看医生信息,查看公告资讯,在科室信息里面进行预约,也可以取消预约。微信小程序医院挂号预约系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值