poj3026 Borg Maze

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12676 Accepted: 4139

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11
这个题说的是S要和所有的A汇合,最少要走多少的步数。实际上就是一个bfs+最小生成树。

我们先找出,S和A点之间的最短距离作为两点的权值,然后求一个最小生成树,表示弄了一个下午QAQ。

先是注意字符串里面是有空格的,不能用scanf读取,用gets;

然后还是一直TLE,之后想了想,最多能够有2500个点的,如果每两两点之间都去bfs一下,复杂度确实太高了QAQ,看了一下别人,猛然醒悟,确实可以每个点只需要一次bfs就行了,感觉被自己蠢哭了,每个点遍历一次,这样这个点到其余点之间的最短距离都可以bfs出来的,这个只需要加一个标记数组就可以,只要搜到了点就附上相应的权值即可QAQ


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
const int inf=0x3f3f3f;
int n,m;
int vis[52][52];
char s[52][52];
int tu[2520][2520];
int dx[4]={-1,1,0,0};
int dy[4]={0,0,1,-1};
int Map[52][52];
struct node
{
    int x,y,step;
};
void bfs(int sx,int sy)
{
    memset(vis,0,sizeof(vis));
    int i;
    node k,t;
    k.x=sx;
    k.y=sy;
    k.step=0;
    queue<node>q;
    q.push(k);
    vis[k.x][k.y]=1;
    int sum=0;
    while(!q.empty())
    {
        k=q.front();
        q.pop();
        if(Map[k.x][k.y])tu[Map[sx][sy]][Map[k.x][k.y]]=k.step;
        for(i=0;i<4;++i)
        {
            int x=k.x+dx[i];
            int y=k.y+dy[i];
            if(x>=0&&x<n&&y>=0&&y<m&&!vis[x][y]&&s[x][y]!='#')
            {
                vis[x][y]=1;
                t.x=x;
                t.y=y;
                t.step=k.step+1;
                q.push(t);
            }
        }
    }
}
int v[2520],dis[2520];
void prim(int n)
{
    int i,j;

    for(i=1;i<=n;++i)
    {
        dis[i]=tu[1][i];
        v[i]=0;
    }
    v[1]=1;
    int sum=0,mm,pos;
    for(i=0;i<n-1;++i)
    {
         mm=inf;
         for(j=1;j<=n;++j)
         {
             if(!v[j]&&dis[j]<mm)
             {
                 mm=dis[j];
                 pos=j;
             }
         }
         v[pos]=1;
         sum+=mm;
         for(j=1;j<=n;++j)if(!v[j]&&dis[j]>tu[pos][j])dis[j]=tu[pos][j];
    }
    printf("%d\n",sum);
}

int main()
{
    int t ,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d\n",&m,&n);
        int cnt=0;
        for(i=0;i<n;++i)
        {
            gets(s[i]);
            for(j=0;j<m;++j)
            {
                if(s[i][j]=='S'||s[i][j]=='A')
                {
                    Map[i][j]=++cnt;
                }
                else Map[i][j]=0;
            }
        }
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
        {
            if(Map[i][j])bfs(i,j);
        }
        prim(cnt);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值