poj1129 Channel Allocation

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14326 Accepted: 7302

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 
这个题的意思是说要在N个点上建立中继站,然后为了每个点互不影响,临近点之间不能用同一个基站,然后它会给你N组关系,告诉你a:b1,b2,b3....  表示bx跟a是相临近的。

问你最少需要多少个基站。

因为最多有26个点所以直接暴力就好了,也没有剪枝,就是从第一个点开始列举,对于每个点来说,从已经建立的基站中选一个,如果可以选择,那么就标记这个点建立了num号基站,如果建立的基站都有冲突,那么这个点就建一个新的基站,一直搜索到最后一个点就可以了,就是贪心的思想。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <vector>
using namespace std;
const int inf =0x3f3f3f;
const int MAXN=30;
int cnt,n;
vector<int>head[MAXN];
int vis[MAXN];
char s[MAXN];
int dfs(int x)
{
    if(x==n)return cnt;//搜索完最后一个点表示搜索完成返回
    int i,j;
    int l=head[x].size();
    for(i=1;i<=cnt;++i)//列举已经建立的基站编号
    {
        for(j=0;j<l;++j)
        {
            if(vis[head[x][j]]==i)break;//如果临近点已经建立,有冲突就寻找下一个点
        }
        if(j==l)//如果没有冲突,那就用这个编号的基站
        {
            vis[x]=i;
            break;
        }
    }
    if(!vis[x])vis[x]=++cnt;//如果都有冲突,建立新的基站
    return dfs(x+1);
}

int main()
{
    int i,j;
    while(~scanf("%d",&n)&&n)
    {
        for(i=0;i<n;++i)
        {
            scanf("%s",s);
            int l=strlen(s);
            head[i].clear();
            for(j=2;j<l;++j)head[i].push_back(s[j]-'A');
        }
        memset(vis,0,sizeof(vis));
        cnt=0;
        int ans=dfs(0);
        if(ans==1)
        printf("1 channel needed.\n");
        else printf("%d channels needed.\n",ans);

    }
    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值