poj1260 Pearls


Pearls
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8699 Accepted: 4351

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344
这道题就是告诉你一些种类的珍珠,现在需要加工,每种珍珠的数量是a[i],然后需要的加工费是p[i],而计算全部珍珠的加工费时,需要加上一些特殊的费用,总的费用是modey[i]=(a[i]+10)*p[i],然后每种珍珠可以和更高级的珍珠一块加工,也就是可以SUMmoney[i]=(num[i]+num[i-1]+10)*p[i],而如果分开加工的时候

SUMmoney[i]=(num[i-1]+10)*p[i-1]+(num[i]+10)*p[i],然后问你全部加工完最少需要多少钱。

输入:第一个组数t,然后n种珍珠(珍珠等级是从小到大排好序的),之后n行每行是数量a[i],单个加工费p[i]。

思路:用dp[i]来记录到i种类珍珠加工的最少总费用

首先要想明白一共有多少种状态,每到一个更高种类珍珠的时候,要么单独加工,此时就是dp[i]=dp[i-1]+money[i](找上文),如果不单独加工,那么它就可以和前面的种类一起买,此时新增的状态就是和前面两种一起,和前面3种一起,……和前面i种一起,此时就是dp[i]=dp[j]+SUMmoney(从第j+1种到第i种一起加工)。这样就可以枚举,每次更新最小值就可以了。为了方便枚举,我们要用一个数组来记录(各种珍珠的数量的)前缀和。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN=100+5;
const int inf=0x3f3f3f;
int v[MAXN],w[MAXN];
int sum[MAXN];
int dp[100005];
int n;
int money(int v,int w)//计算加工v数量的加工单价为w的总钱数
{
    return (v+10)*w;
}
int main()
{
    int t;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;++i)
        {
            scanf("%d%d",&v[i],&w[i]);
            sum[i]=sum[i-1]+v[i];//用sum当前缀和数组
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;++i)
        {
            dp[i]=dp[i-1]+money(v[i],w[i]);//默认就是单独自己加工
            for(j=0;j<i-1;++j)dp[i]=min(dp[i],dp[j]+money(sum[i]-sum[j],w[i]));//然后依次枚举和前面的i~1种珍珠一起加工
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值