poj3122 Pie


Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14948 Accepted: 5130 Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are  cylindrical (圆柱形的) in shape and they all have the same height 1, but the  radii (半径) of the pies can be different.

Input

One line with a  positive (积极的)  integer (整数): the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii(半径) of the pies.

Output

For each test case,  output (输出) one line with the largest possible  volume (量) V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute (绝对的) error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655
题意:某人要过生日,然后他准备了很多的馅饼,现在的问题是他的朋友们很容易吃醋,如果他不小心分给朋友们的馅饼尺寸不一样大,那么尺寸较小的朋友便会吃醋,太(ji)美(qing)妙(man)了(man),馅饼都是圆柱型的,然后现在告诉你每个馅饼的半径,问他和他的朋友们最大能够分得的馅饼体积。我们宴会的主人,也是分的一样的尺寸的(反正你们走了剩下的都是我的)。注意:每个人分得的部分只能是一个馅饼的。

(表示这次很快就联想到了二分呢)

思路:二分答案,最少的尺寸必然是其中一个最大的馅饼分成F+1份(F是朋友的个数),最大值便可以取其中最大的一个馅饼的体积。

看示例保留4位小数,这里循环结束条件我设了high-low<1e-5。

剩下的看代码吧:

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const double pai=acos(-1);
const double eps=1e-5;
const int MAXN=10000+10;
double v[MAXN];
int n,m;
double low,high;
bool judge(double mid)
{
    int i=0,cnt=0;
    for(i=0;i<n;++i)
    {
        cnt+=v[i]/mid;//每个馅饼最多可以分得的人数
    }
    if(cnt>=m)return 1;
    else return 0;
}

void solve()
{
    double mid;
    while(high-low>eps)//他们两个相差不超过1e-5的时候,结束
    {
        mid=(low+high)/2;
        if(judge(mid))//符合条件不一定是最大的
        {
            low=mid;
        }
        else high=mid;
    }
    printf("%.4f\n",mid);
}

int main()
{
    int t,i;
    int r;
    scanf("%d",&t);
    while(t--)
    {
        low=1000000000.0;high=0.0;
        scanf("%d%d",&n,&m);
        m++;
        for(i=0;i<n;++i)
        {
            scanf("%d",&r);
            v[i]=pai*r*r;
            low=min(low,v[i]/m);
            high=max(high,v[i]);
        }
        solve();
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值