poj1459 Power Network

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 27258 Accepted: 14171

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

今天学习了最大流算法,总的来说,基本的算法理解上和操作上并不难。

这个题是告诉你:n个点,np个发电站,nc个用户,m条路径。

m:(u,v)u到v的能通过的最大流。np:发电站能发出的最大流。nc:用户能接收到的最大流。

思路:

这里建图需要虚拟一个s起始点和e汇点,把s和每个发电站相连,权值为发电站的最大流,把用户和e相连,权值为用户能接受到的最大流。

那么问题就转化为了简单的s-t的最大流问题。这里首先学习的是EK算法,核心是BFS。

有关EK算法,这里写还算可以:点我点我~具体的可以看一下紫书上的366页,讲的比较详细。那个网站上帮我弄明白了一个回弧的问题。


总的来说就是不断构建图,开始图上的流量全为0,原图是残余图,残余图就是剩下的可以走的流量图。

该算法基于这样一个事实:残留网络中任何一条从 s t 的有向道路都对应一条原图中的增广路——只要求出该道路中所有残留量的最小值d,把对应的所有边上的流量增加d即可,这个过程称为增广。不难验证,如果增广前的流量满足3个条件,增广后仍然满足。显然,只要残留网络中不存在增广路,则当前流就是最大流。这就是伟大的增广路定理~。

也就是当且仅当残留网络中不存在s-t的有向道路(增广路)时,此时的流就是s-t的最大流。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cstring>
using namespace std;
const int MAXN=100+10;
const int inf = 0x3f3f3f3f;
int tu[MAXN][MAXN],path[MAXN],flow[MAXN];
int n,m,np,nc;
int bfs()
{
    int i,k;
    memset(path,-1,sizeof(path));
    flow[0]=inf;
    path[0]=0;
    queue<int>q;
    q.push(0);
    while(!q.empty())
    {
        k=q.front();
        q.pop();
        if(k==n)break;
        for(i=1;i<=n;++i)
        {
            if(path[i]==-1&&tu[k][i])
            {
                flow[i]=min(flow[k],tu[k][i]);
                q.push(i);
                path[i]=k;
            }
        }
    }
    if(path[n]==-1)return -1;
    else return flow[n];
}
int Edmonds_Karp()
{
    int max_flow=0,step,e,pre;
    while((step=bfs())!=-1)
    {
        max_flow+=step;
        e=n;
        while(e!=0)
        {
            pre=path[e];
            tu[pre][e]-=step;
            tu[e][pre]+=step;
            e=pre;
        }
    }
    return max_flow;
}
int main()
{
    int u,v,w;
    while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
    {
        memset(tu,0,sizeof(tu));
        while(m--)
        {
            while(getchar()!='(');
            scanf("%d,%d)%d",&u,&v,&w);
            u++;v++;
            tu[u][v]=w;
        }
        while(np--)
        {
            while(getchar()!='(');
            scanf("%d)%d",&u,&w);
            u++;
            tu[0][u]=w;
        }
        while(nc--)
        {
            while(getchar()!='(');
            scanf("%d)%d",&u,&w);
            u++;
            tu[u][n+1]=w;
        }
        n++;
        printf("%d\n",Edmonds_Karp());
    }
    return 0;
}





  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值