poj2528 Mayor's posters

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 61616 Accepted: 17812

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
大意:有一面长度1e7的墙,然后告诉你张贴的海报的顺序以及覆盖的位置。让你计算最后能看到的最多的海报数。

用线段树处理,刚接触这东西,还不是很懂,然后需要离散化,因为最多10000个区间,20000个点,你不可能直接开1e7这么大的空间。

不知道为什么要开8倍空间。

按理说两倍空间应该够了,只能说是数据了吧。

作为线段树的题应该说并不是很难,重点是离散化。

注意!!!离散化的时候,如果区间不相邻的那么在编号的时候不要编成相邻的。这个poj数据水,根本没考虑过这样的数据!!。

张贴海报,就是区间更新,我们从最后一张张贴的海报开始。

附上几组数据:

5

3
1 10
1 3
6 10

6
2 9
2 17
14 15
21 23
15 18
26 26

3
5 6
4 5
6 8

3
1 10
1 3
6 10

5
1 4
2 6
8 10
3 4
7 10
正确答案自然是3 5 2 3 4.自己画图看看就知道了。

附上正确的代码:

//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN=1e4+7;
int n,m;
int postl[MAXN],postr[MAXN];
struct node
{
    int l,r;
    bool iscover;
}tree[MAXN<<4];
int ha[10000005];
int p[MAXN<<1];
void build_tree(int i,int l,int r)
{
    tree[i].l=l;
    tree[i].r=r;
    tree[i].iscover=0;
    if(l==r)return;
    int mid=(l+r)>>1;
    build_tree(i<<1,l,mid);
    build_tree(i<<1|1,mid+1,r);
}
bool post(int i,int l,int r)//贴上一张海报
{
    if(tree[i].iscover)return 0;//如果大区间已经被覆盖
    if(tree[i].l==l&&tree[i].r==r)//如果没被覆盖过
    {
        tree[i].iscover=1;
        return 1;
    }
    int mid=(tree[i].l+tree[i].r)>>1;
    bool ans;
    if(r<=mid)ans=post(i<<1,l,r);
    else if(l>mid)ans=post(i<<1|1,l,r);
    else
    {
        int p1=post(i<<1,l,mid);
        int p2=post(i<<1|1,mid+1,r);
        ans=p1||p2;
    }
    //向上更新
    if(tree[i<<1].iscover&&tree[i<<1|1].iscover)tree[i].iscover=1;
    return ans;
}
int main()
{
    int t;
    int cnt;
    scanf("%d",&t);
    while(t--)
    {
        cnt=0;
        scanf("%d",&n);
        for(int i=0;i<n;++i)
        {
            scanf("%d%d",&postl[i],&postr[i]);
            p[cnt++]=postl[i];
            p[cnt++]=postr[i];
        }
        sort(p,p+cnt);
        cnt=unique(p,p+cnt)-p;
        int pos=0;
        ha[p[0]]=0;
        for(int i=1;i<cnt;++i)
        {
            if(p[i]-p[i-1]==1)ha[p[i]]=++pos;
            else
            {
                pos+=2;
                ha[p[i]]=pos;
            }
        }
        build_tree(1,0,pos);
        int ans=0;
        for(int i=n-1;i>=0;--i)
        {
            if(post(1,ha[postl[i]],ha[postr[i]]))ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值