D - Coconuts HDU - 5925

TanBig, a friend of Mr. Frog, likes eating very much, so he always has dreams about eating. One day, TanBig dreams of a field of coconuts, and the field looks like a large chessboard which has R rows and C columns. In every cell of the field, there is one coconut. Unfortunately, some of the coconuts have gone bad. For sake of his health, TanBig will eat the coconuts following the rule that he can only eat good coconuts and can only eat a connected component of good coconuts one time(you can consider the bad coconuts as barriers, and the good coconuts are 4-connected, which means one coconut in cell (x, y) is connected to (x - 1, y), (x + 1, y), (x, y + 1), (x, y - 1). 

Now TanBig wants to know how many times he needs to eat all the good coconuts in the field, and how many coconuts he would eat each time(the area of each 4-connected component). 
Input
The first line contains apositiveinteger T( T10 T≤10) which denotes the test cases. T test cases begin from the second line. In every test case, the first line contains two integers R and C,  0<R,C109 0<R,C≤109 the second line contains an integer n, the number of bad coconuts,  0n200 0≤n≤200 from the third line, there comes n lines, each line contains two integers,  xi xi and  yi yi, which means in cell( xi,yi xi,yi), there is a bad coconut. 

It is guaranteed that in the input data, the first row and the last row will not have bad coconuts at the same time, the first column and the last column will not have bad coconuts at the same time. 
Output
For each test case, output "Case #x:" in the first line, where x denotes the number of test case, one integer k in the second line, denoting the number of times TanBig needs, in the third line, k integers denoting the number of coconuts he would eat each time, you should output them in increasing order.
Sample Input
2

3 3
2
1 2
2 1

3 3
1
2 2
Sample Output
Case #1:
2
1 6
Case #2:
1
8


题意:求连通块的个数,以及每个联通块中点的个数。

思路:范围很大,所以要离散化坐标轴。

给出的是障碍点。那么不是障碍的点离散化之后都会是一个矩形。搜索每个点的时候我们每次加上矩形的面积,最后求出总和。


#include <bits/stdc++.h>
using namespace std;
const int MAXN=300;
bool vis[MAXN][MAXN];
int x[MAXN],y[MAXN];
map<int,int>x_cnt,y_cnt;
int pointx[MAXN],pointy[MAXN];
long long ans[MAXN];
vector<long long>lenx,leny;
int n,m,k;
long long sum;
int dx[4]= {0,0,1,-1};
int dy[4]= {1,-1,0,0};
void dfs(int x,int y)
{
    vis[x][y]=1;
    sum+=lenx[x]*leny[y];
    for(int i=0; i<4; ++i)
    {
        int nx=x+dx[i];
        int ny=y+dy[i];
        if(nx>=0&&nx<int(lenx.size())&&ny>=0&&ny<int(leny.size())&&!vis[nx][ny])
        {
            dfs(nx,ny);
        }
    }
}
void init()
{
    x_cnt.clear();
    y_cnt.clear();
    lenx.clear();
    leny.clear();
    memset(vis,0,sizeof(vis));
}
int main()
{
    int t;
    int i,j;
    scanf("%d",&t);
    for(int tt=1; tt<=t; ++tt)
    {
        init();
        scanf("%d%d",&n,&m);
        int cnt1=0,cnt2=0;
        x[cnt1++]=y[cnt2++]=0;
        x[cnt1++]=n;
        y[cnt2++]=m;
        scanf("%d",&k);
        for(i=0; i<k; ++i)
        {
            scanf("%d%d",&pointx[i],&pointy[i]);
            x[cnt1++]=pointx[i];
            y[cnt2++]=pointy[i];
        }
        sort(x,x+cnt1);
        sort(y,y+cnt2);
        cnt1=unique(x,x+cnt1)-x;
        cnt2=unique(y,y+cnt2)-y;
        for(i=1; i<cnt1; ++i)
        {
            int len=x[i]-x[i-1];
            if(len>1)
            {
                lenx.push_back(len-1);//不包括障碍点,空白的点连接起来的长度
            }
            lenx.push_back(1);//障碍点单独算,长度必定为1
            x_cnt[x[i]]=lenx.size()-1;
        }
        for(i=1; i<cnt2; ++i)
        {
            int len=y[i]-y[i-1];
            if(len>1)
            {
                leny.push_back(len-1);//不包括障碍点,空白的点连接起来的长度
            }
            leny.push_back(1);//障碍点单独算,长度必定为1
            y_cnt[y[i]]=leny.size()-1;
        }
        for(i=0; i<k; ++i)
        {
            vis[x_cnt[pointx[i]]][y_cnt[pointy[i]]]=1;
        }
        int cnt=0;
        for(i=0; i<int(lenx.size()); ++i)
        {
            for(j=0; j<int(leny.size()); ++j)
            {
                if(!vis[i][j])
                {
                    sum=0;
                    dfs(i,j);
                    ans[cnt++]=sum;
                }
            }
        }
        sort(ans,ans+cnt);
        printf("Case #%d:\n",tt);
        printf("%d\n",cnt);
        for(i=0; i<cnt; ++i)printf(i==cnt-1?"%I64d\n":"%I64d ",ans[i]);
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值