poj2482 Stars in Your Window

Stars in Your Window
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12087 Accepted: 3303

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting. 

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently. 

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert. 

Farewell, my princess! 

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together. 

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed. 

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point. 

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31. 

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

题意:经典题,给你一个矩阵的大小,然后告诉你n个点的坐标,每个点都有一个值,你可以用矩阵来框住一些点,然后让你求出你能框出的点的总和的最大值是多少。

思路:范围很大,马上想到离散化。但发现并不好做,完全不知道怎么继续下手,因为你的矩阵大小不可能也离散化掉的。

这里需要换一个思维.

转换一下,就能把其转换为求线段区间的最大值 每个星星所能影响的范围[(x,y),(x+w-1,y+h-1)]且有一权值 它们重合就表示 能被这个矩形框在一起,也就是说,只要求出重合的矩形的权值最大就行了。

以x从小到大排序,y值离散化,投影到y轴上,那么对于每个星星的纵坐标,y,y+h-1就是每个星星可以影响到的矩形 然后x,x+w-1就是一个进入事件和一个出去事件,其所带的值互为相反数. node[1].sum 保存当前的最大值 当所有的矩形都遍历一遍 取其中的最大值就是ans.

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN=1e4+7;
int n,w,h;

struct node
{
    long long x,y1,y2,val;
    bool operator<(const node &a)const
    {
        if(x!=a.x)return x<a.x;
        return val>a.val;//这个地方不能少,不然所得的值可能比答案小的。
    }
}seg[MAXN<<1];

struct tree
{
    int l,r;
    long long sum,add;
}tree[MAXN<<3];
long long y[MAXN<<1];

void build_tree(int i,int l,int r)
{
    tree[i].l=l;
    tree[i].r=r;
    tree[i].add=tree[i].sum=0;
    if(l==r)return ;
    int mid=(l+r)>>1;
    build_tree(i<<1,l,mid);
    build_tree(i<<1|1,mid+1,r);
}

void push_down(int i)//向下更新
{
    tree[i<<1].add+=tree[i].add;
    tree[i<<1].sum+=tree[i].add;
    tree[i<<1|1].add+=tree[i].add;
    tree[i<<1|1].sum+=tree[i].add;
    tree[i].add=0;
}

void updata(int i,long long l,long long r,long long val)
{
    if(l==y[tree[i].l]&&r==y[tree[i].r])
    {
        tree[i].sum+=val;
        tree[i].add+=val;
        return ;
    }
    if(tree[i].add)push_down(i);
    int mid=(tree[i].l+tree[i].r)>>1;
    if(r<=y[mid])updata(i<<1,l,r,val);
    else if(l>y[mid])updata(i<<1|1,l,r,val);
    else
    {
        updata(i<<1,l,y[mid],val);
        updata(i<<1|1,y[mid+1],r,val);
    }
    tree[i].sum=max(tree[i<<1].sum,tree[i<<1|1].sum);//向上更新
}
int main()
{
    int i;
    while(~scanf("%d%d%d",&n,&w,&h))
    {
        for(i=0;i<n;++i)
        {
            scanf("%I64d%I64d%I64d",&seg[i].x,&seg[i].y1,&seg[i].val);
            seg[i].y2=seg[i].y1+h-1;
            seg[i+n]=seg[i];
            seg[i+n].x=seg[i].x+w-1;
            seg[i+n].val=-seg[i].val;
            y[i*2+1]=seg[i].y1;
            y[i*2+2]=seg[i].y2;
        }
        sort(y+1,y+2*n+1);
        sort(seg,seg+2*n);
        int cnt=unique(y+1,y+2*n+1)-y-1;//去重函数,离散化基本就有它
        build_tree(1,1,cnt);
        long long ans=0;
        for(i=0;i<n*2;++i)
        {
            updata(1,seg[i].y1,seg[i].y2,seg[i].val);
            ans=max(ans,tree[1].sum);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值