Find a way

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 
Input
The input contains multiple test cases. 
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character. 
‘Y’ express yifenfei initial position. 
‘M’    express Merceki initial position. 
‘#’ forbid road; 
‘.’ Road. 
‘@’ KCF 
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
Sample Output
66
88
66

题意:Y和M要到同一个@ 里面去,问你所需要的最少花费是多少,最少花费=最少步数*11,所以就是求的最少步数。

巧妙的bfs,只搜索两个点Y和M,然后搜索的过程中记录@的最小步数就可以了。最后枚举更新答案即可。

#include <cstdio>
#include <queue>
#include <cstring>

using namespace std;
const int MAXN=200+7;
const int inf=1e9;
int n ,m;
int cnt;
int sx1,sy1,sx2,sy2;
int ans;
char tu[MAXN][MAXN];
bool vis[MAXN][MAXN];
int step[MAXN][MAXN];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};

struct node
{
    int x,y,step;
    node(int a,int b,int c)
    {
        x=a;
        y=b;
        step=c;
    }
};


void  bfs(int sx,int sy)
{
    queue<node>q;
    memset(vis,0,sizeof(vis));
    vis[sx][sy]=1;
    q.push(node(sx,sy,0));
    while(!q.empty())
    {
        node u=q.front();
        q.pop();
        if(tu[u.x][u.y]=='@')
        {
            step[u.x][u.y]+=u.step;
        }
        for(int i = 0;i < 4 ; ++i)
        {
            int nx=u.x+dx[i];
            int ny=u.y+dy[i];
            if(nx>=0&&nx<n&&ny>=0&&ny<m&&!vis[nx][ny]&&tu[nx][ny]!='#')
            {
                vis[nx][ny]=1;
                q.push(node(nx,ny,u.step+1));
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        cnt=0;
        for(int i = 0 ; i < n ; ++i)
        {
            scanf("%s",tu[i]);
            for(int j = 0 ; j < m ; ++j)
            {
                if(tu[i][j]=='Y')
                {
                    sx1 = i;
                    sy1 = j;
                }
                else if(tu[i][j]=='M')
                {
                    sx2 = i;
                    sy2 = j;
                }
            }
        }
        memset(step,0,sizeof(step));
        bfs(sx1,sy1);
        bfs(sx2,sy2);
        ans=inf;
        for(int i = 0;i < n; ++i)
            for(int j = 0;j < m; ++j)
        {
            if(!step[i][j])continue;
            ans = min(ans,step[i][j]);
        }
        printf("%d\n",ans*11);
    }
    return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值