迷宫问题

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


思路:简单bfs记录路径的问题。

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
using namespace std;
int n,m;
int tu[10][10];
bool vis[10][10];
int dx[4] = {0,0,-1,1};
int dy[4] = {1,-1,0,0};

struct node
{
    int x,y;
    string step;
    node(int a,int b,string c)
    {
        x=a;
        y=b;
        step=c;
    }
};
string bfs()
{
    queue<node>q;
    q.push(node(0,0,"00"));
    vis[0][0]=1;
    while(!q.empty())
    {
        node u = q.front();
        q.pop();
        if(u.x==4&&u.y==4)return u.step;
        for(int i = 0 ;i < 4 ;++i)
        {
            int nx = u.x + dx[i];
            int ny = u.y + dy[i];
            if(nx >= 0 && nx < 5 && ny >= 0 && ny <5 && !tu[nx][ny] && !vis[nx][ny])
            {
                vis[nx][ny] = 1;
                q.push(node(nx,ny,u.step+char(nx+'0')+char(ny+'0')));
            }
        }
    }
}
int main()
{
    for(int i = 0 ; i < 5 ; ++i)
        for(int j = 0 ; j < 5 ; ++j)scanf("%d",&tu[i][j]);
    string ans=bfs();
    for(int i = 0 ; i < (int)ans.size() ; i+=2)
    {
        printf("(%c, %c)\n",ans[i],ans[i+1]);
    }
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值