HDU 4352 XHXJ's LIS

#define xhxj (Xin Hang senior sister(学姐)) 
If you do not know xhxj, then carefully reading the entire description is very important. 
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu. 
Like many god cattles, xhxj has a legendary life: 
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final. 
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type. 
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls. 
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in  LR L,Rin O(1)time. 
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.( 
0<L<=R<2  63-1 and 1<=K<=10).
Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
Sample Input
1
123 321 2
Sample Output
Case #1: 139 


题目大意:

就是现在对于每个正整数可以将其每位视为一个数形成一个串, 那么这一组数就存在一个最长上升子序列, 对于每组给出的L, R (0 < L <= R <= 2^63 - 1) 求出在区间[L, R]中有多少个数在视作这样的一组数后最长上升子序列的长度是K

大概思路就是:我们仔细考虑求LIS的那个O(nlogn)的那个算法。用二进制压缩状态。因为你数字的LIS不会超过9位。所以这两个结合之后就是

  1.  * 这个数的二进制第i个1的位置表示在当前的序列中, 长度为i的上升子序列结尾的数最小是多少 
  2.  * 例如0110110010就表示当前LIS以8结尾, 当前长度为1, 2, 3, 4, 5的上升子序列最小的结尾分别是1, 4, 5, 7, 8 
  3.  * 而这个二进制中的1的总个数就是LIS的长度 

这样我们就可以转移了。每次加长一个数字的时候,我们找到第一个大于等于当前数字的第一个数字,然后替换掉。(具体看代码的change函数)

这样我们定义dp[i][j][k]表示长度为i位,状态为j,满足LIS为k的数的个数。

注意:

这里要特别注意前面的0的问题。0是不计算在内的。那么状态转移的时候0+0可能就会出来1,这样后面的状态就是错误的了。因为不存在0587这样有前导0的数。

#include <bits/stdc++.h>

using namespace std;
typedef long long LL;
const int MAXN=1e5+10;
int k;
LL l,r;
LL dp[25][1<<10][12];
int change(int state,int x)
{
    for(int i = x ; i <= 9 ; ++i)
    {
        if(state & (1<<i))
        {
            state ^= (1<<i);
            break;
        }
    }
    return state | (1<<x);
}
int digit[25];
LL dfs(int len,int state,bool up,bool zero)
{
    if(len == -1)return __builtin_popcount(state) == k;
    if(!up && dp[len][state][k] != -1)return dp[len][state][k];
    LL res = 0;
    int n = up?digit[len] : 9;
    for(int i = 0 ; i <= n ; ++i)
    {
        res += dfs(len-1,zero && i==0 ? 0 : change(state,i),up&&i==n,zero&&i==0);
    }
    if(!up)dp[len][state][k] = res;
    return res;
}
LL cal(LL x)
{
    int len = 0;
    while(x)
    {
        digit[len++] = x%10;
        x /=10 ;
    }
    return dfs(len - 1,0,1,1);
}

int main()
{
    int t;
    memset(dp,-1,sizeof dp);
    scanf("%d",&t);
    for(int tt = 1 ; tt <= t ; ++tt)
    {
        scanf("%I64d %I64d %d",&l,&r,&k);
        printf("Case #%d: %I64d\n",tt,cal(r) - cal(l-1));
    }
    return 0;
}












  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值