【ZOJ 1403】

ZOJ 1403(Safecracer) 

problem descrption:

The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.

v - w^2 + x^3 - y^4 + z^5 = target

For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then.

 

Sample Input

 

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END


Sample Output

LKEBA
YOXUZ
GHOST
no solution

 

题意简述:

        密码序列由一系列大写字母组成,在解密序列不唯一的情况下,按字典序输出最后一个,解密公式:v - w^2 + x^3 - y^4 + z^5 = target ,其中target为数字,v,w,x,y,z都是题给的集合中的同一个元素,且各不相同,该集合由题目给出,由26个大写字母的任意5-12个组成,每个

字母对应的数值,以此类推(A=1,B=2,...,Z=26)

解法:枚举法(尽管枚举的算法复杂度为指数级,但是由于集合元素有限,因此可以直接枚举),题目要求按照字典序输出最后一个,所以需要事先对集合进行排序

 

 

 

  

 

 

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;


     int a,b,c,d,e;
	 char letters[15];
	 int value[15],target;
	 void process(int len)
	 {
	        int a,b,c,d,e;
		      for(a=0;a<len;a++)
		          for(b=0;b<len;b++)
		             if(a!=b)
		                for(c=0;c<len;c++)
		                   if(a!=c&&b!=c)
		                       for(d=0;d<len;d++)
					   if(a!=d&&b!=d&&c!=d)
						for(e=0;e<len;e++)
					             if(a!=b&&b!=e&&c!=e&&d!=e)    
								if(value[a]-pow(value[b],2.0)+pow(value[c],3.0)-pow(value[d],4.0)+pow(value[e],5)==target)
									{
											
									       printf("%c%c%c%c%c\n",value[a]+'A'-1,value[b]+'A'-1,value[c]+'A'-1,value[d]+'A'-1,value[e]+'A'-1);	
									       return;
								        }
										    
	  printf("no solution\n");										
	}
	bool compare(int a,int b)
	{
		return a>b;      //降序排列,如果return a<b,则为升序排列 
	}
int main()
{
      int i;
	  while(~scanf("%d %s",&target,letters))
	  {
	  	if(target==0&strcmp(letters,"END")==0)
	  	{
	  	      return 0;	
		}
		i=0;
		while(letters[i])
		{
			value[i]=letters[i]-'A'+1;
			i++;
	    }
	    sort(value,value+i,compare);
	    process(i); 
	  } 
	  
	return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值