HDU 1015 Safecracker (搜索)

31 篇文章 0 订阅

Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST ===
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

题意是给一个num和一个string  从string中 找到五个字符满足a[1]- a[2]^2 + a[3]^3 - a[4]^4 + a[5]^5 = num

如果有多个答案,取最大的字符串。用DFS找到满足条件的串,再存入string数组中,排序取最大的即可。

 

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
char a[20], s[20];
string ANS[1010];
int b[20], sum, flag = 0, len, x = 0;
int pow1(int a, int b){            //计算a的b次方 
	int res = 1;
	while (b){
		if (b & 1)
			res *= a;
		a *= a;
		b >>= 1;
	}
	return res;
}
int total(char *a){           //将字符串按题目要求转化成数字 
	int all = 0;
	for (int i = 0; i < 5; i++)
		if (i == 1 || i == 3)
			all -= pow1(a[i] - 'A' + 1, i + 1);
		else
			all += pow1(a[i] - 'A' + 1, i + 1);
	return all;
}
void dfs(int d){
	if (d == 5){     //如果当前字符串长度为5 
		if (total(a) == sum)   //若等于sum,则存入ANS数组 
		{
			flag = 1;
			string b;
			for (int i = 0; i < 5; i++)
				b.push_back(a[i]);
			ANS[x++] = b;
		}
	}
	else {
		for (int i = 0; i < len; i++)
			if (b[i] == 0)      //如果当前位置没有用过,进入下一层 
				a[d] = s[i], b[i] = 1, dfs(d + 1), b[i] = 0;
	}
}
int main(){
	while (scanf("%d%s", &sum, s))
	{
		if (sum == 0 && strcmp(s, "END") == 0)
			break;
		flag = 0, x = 0;
		memset(b, 0, sizeof(b));
		len = strlen(s);
		dfs(0);
		if (flag == 0)cout << "no solution" << endl;
		else {
			sort(ANS, ANS + x);
			cout << ANS[x - 1] << endl;    //取最大的字符串 
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值