百炼1248 Safecracker(dfs+暴力)

描述

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w2+ x3- y4+ z5= target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 92+ 53- 34+ 25= 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 


"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. 
 

输入Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input.输出For each line output the unique Klein combination, or 'no solution' if there is no correct combination. Use the exact format shown below."样例输入

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

样例输出

LKEBA
YOXUZ
GHOST
no solution

 

 

之前做的DFS的题都是图的,但是dfs实际上是用递归解决问题的一种思想,因此本题可以采用dfs解决。调试的过程中第二组数据出来的答案一直不对,后来发现是pow出来的是double,若直接赋给int,会产生误差,导致最后误判,因此只需要将计算的值赋给double,再将target转换成target与之对比即可

 

#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

int N;
char letters[20];
int num[20];
int temp[10];
int key[10];
int flag[20];
int first;
int target;

bool cmp(int a,int b)
{
    return a>b;
}

void dfs(int i)
{
    if(first==1)
    {
        if(i==5)
        {
            double a=temp[0]-pow(temp[1],2)+pow(temp[2],3)-pow(temp[3],4)+pow(temp[4],5);
            if(a==target)
            {
                for(int j=0; j<5; j++)
                {
                    key[j]=temp[j];
                    first=0;
                }
            }
        }
        else
        {
            for(int j=0; j<N; j++)
            {
                if(flag[j]==0)
                {
                    temp[i]=num[j];
                    flag[j]=1;
                    dfs(i+1);
                    flag[j]=0;
                }
            }
        }
    }
}

int main()
{

    while(scanf("%d",&target)&&target!=0)
    {
        memset(letters,0,sizeof(letters));
        memset(flag,0,sizeof(flag));
        memset(key,0,sizeof(key));
        memset(temp,0,sizeof(temp));
        memset(num,0,sizeof(num));
        first=1;

        scanf("%s",letters);

        N=strlen(letters);

        for(int i=0; i<N; i++)
        {
            num[i]=letters[i]-'A'+1;
        }

        sort(num,num+N,cmp);

        dfs(0);

        if(key[0]!=0)
        {
            char c;
            for(int i=0; i<5; i++)
            {
                c=key[i]-1+'A';
                printf("%c",c);
            }

            printf("\n");
        }
        else
        {
            printf("no solution\n");
        }

    }

    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值