zzuli蓝桥 text1 D find sum

爆搜题;

因为只有两个数想加

不需要用线段树区间求和;

Description

This problem is really boring.

You are given a number sequence S which contain n integers and m queries, each time i will give your two integers id1 and id2, you need to tell me whether i can get S[id1] + S[id2] from the n integers.

Input

Input starts with an integer T(T <= 5) denoting the number of test cases.
For each test case, n(1 <= n <= 100000, 1 <= m <= 10000) are given, and the second line contains n integers, each of them is larger then 0 and no larger than 10^11.
Next m lines, each line contains two integers id1 and id2(1 <= id1, id2 <= n).

Output

For each case, first print the case number.
For each query, print “Yes” if i can get S[id1] + S[id2] from S, otherwise print “No”(without the quote).

Sample Input

1
5 3
3 4 2 1 3
1 2
3 4
4 5

Sample Output

Case 1:
No
Yes
Yes


#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define N 100000+100
int sum[N];
using namespace std ;
int main()
{
	int t ;
	scanf("%d",&t);
	for(int i = 1 ; i<=t;i++)
	{
		int n , m ;
		cin>>n>>m;
		int p , q ;
		for(int i = 1 ; i<=n;i++)
		{
			scanf("%d",&sum[i]);
		}
		printf("Case %d:\n",i);
		while(m--)
		{
			int flag = 0 ;
			cin>>p>>q;
			for(int i = 1 ; i <=n;i++)
			{
				if(sum[p]+sum[q]==sum[i])
				{
					printf("Yes\n");
					flag=1;
					break;
				}
			}
			if(!flag)
			printf("No\n");
		}
	}
	return 0 ;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值