【多重背包】 big event in HDU 外加 输入挂写法

Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002. 
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds). 
 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. 
A test case starting with a negative integer terminates input and this test case is not to be processed. 
 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B. 
 

Sample Input

    
    
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output

    
    
20 10 40 40

多重背包的板子题

题意:给出每个物体的价值和物体的数量,如何分使得A,B所得价值最接近并且A的价值不能小于B

思路:将总和平分后,就是一道01背包题了

顺带讲解一下:std::ios::sync_with_stdio(false); 

放在int main 下面。 但是当用了后就不可以在使用scanf和printf否则无限re;

因为关闭了同步,就不允许在使用stdio.h中的输入输出函数了;

AC代码:

#include<iostream>
#include<cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[255000],n;
void wq(int v)
{
    for(int i=v;i<=n;i++)
        dp[i]=dp[i]>dp[i-v]+v?dp[i]:dp[i-v]+v;
}
void b01(int v)
{
    for(int i=n;i>=v;i--)
        dp[i]=dp[i]>dp[i-v]+v?dp[i]:dp[i-v]+v;
}
void dc(int a,int b)
{
    if(a*b>n)
        wq(a);
    else
    {
        int k=1;
        while(k<b)
        {
            b01(k*a);
            b-=k;
            k*=2;
        }
        b01(b*a);
    }
}
int main()
{
    std::ios::sync_with_stdio(false);//*黑科技
    int t,i,o,v[55],m[55];
    while(cin>>t,t>=0)
    {
        memset(dp,0,sizeof(dp));
        o=0;
        for(i=0;i<t;i++)
        {
            cin>>v[i]>>m[i];
            o+=v[i]*m[i];
        }
        n=o/2;
        for(i=0;i<t;i++)
            dc(v[i],m[i]);
        cout<<o-dp[n]<<" "<<dp[n]<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值