POJ 3050 Hopscotch

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 

111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.


题目大意:给一个5X5矩阵,问在任意一点出发,向四周走5步有多少种不同的走法;

题解:用set存储序列,每一个点进行dfs,得到的序列转化为一个数字,重复的序列就不会被计入,然后将容器大小输出即可;

AC代码:

#include <iostream>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std ;
int dp[6][6] ,vis[6][6],ans;
int dir[4][2] = {{-1,0},{1,0},{0,-1},{0,1}};
set<int>ma;
void dfs(int x ,int y , int t ,int sum)
{
    if(t==5)
    {
        ma.insert(sum);
        return;
    }
    for(int i = 0 ; i < 4 ; i++)
    {
        int dx = x + dir[i][0];
        int dy = y + dir[i][1];
        if(dx>=0&&dx<5&&dy>=0&&dy<5)
        {
            dfs(dx,dy,t+1,dp[dx][dy]+sum*10);//*把当前的序列变为一个整数;
        }
    }
}

int main()
{
    for(int i = 0 ; i<5;i++)
    {
        for(int j = 0 ;j<5;j++)
        {
            cin>>dp[i][j];
        }
    }
    for(int i = 0 ; i<5;i++)
    {
        for(int j = 0 ;j<5;j++)
        {
            dfs(i,j,0,dp[i][j]);
        }
    }
    cout<<ma.size()<<endl;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值