13届浙江省省赛 A题 Apples and Ideas

"If you have an apple and I have an apple and we exchange these apples then you and I will still each have one apple. But if you have an idea and I have an idea and we exchange these ideas, then each of us will have two ideas." - George Bernard Shaw

Now Alice has A apples and B ideas, while Bob has C apples and D ideas, what will they have if they exchange all things?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The only line contains four integers ABCD (0 <= ABCD <= 100) - as the problem described.

Output

For each test case, output two lines. First line contains two integers, indicating the number of Alice's apples and ideas; second line contains two integers, indicating the number of Bob's apples and ideas.

Sample Input
4
0 0 5 30
20 25 20 0
20 25 20 15
20 25 25 30
Sample Output
5 30
0 30
20 25
20 25
20 40
20 40
25 55
20 55
 
 
大概题意:苹果相加则是苹果,点子相加则是和;
题解:idea是和 ; appl则分别为两项的值,而表达式为, c , b+d ; a ,b+d ;
AC代码:
#include <bits/stdc++.h>
using namespace std ;
int dp1[50000], dp2[50000];
int main()
{
    int t  ;
    int flag;
    while(cin>>t)
    {
        memset(dp1,0,sizeof(dp1));
        memset(dp2,0,sizeof(dp2));
        int a , b , c  , d ;
        flag = 0 ;
        for(int i = 0 ; i < t ; i++)
        {
            cin>>a>>b>>c>>d;
            int sum = b+d;
            dp1[flag] = c;
            dp2[flag] = sum;
            flag++;
            dp1[flag] = a;
            dp2[flag] = sum;
            flag++;
        }
        for(int i = 0 ; i < flag ; i++)
        {
            printf("%d %d\n",dp1[i],dp2[i]);
        }
    }
    return 0 ;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值